cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
512
Views
5
Helpful
2
Replies
cody.haiden
Enthusiast

TMS/Touch Panel/C-series Codec Issues

I have a few issues I've been seeing with TMS/C-series codecs and the touch panel.

The first issues we have been seeing issues with the directory on the touch panels.  It started with phonebooks disappearing, usually searching the directory would still provide results but without searching the list would just be empty.

The second issue is that TMS seems to loose random endpoints.  TMS shows them as offline, "No HTTP response" or "No SNMP response".  The reality is that the endpoint is online and has a new IP.  If I manually input the new IP in TMS, all is well for a while.

In both of those cases, I've looked at the codec and noticed that references to Phonebook server and external manager point to the FQDN of my TMS server.  I have manually changed on the codec and update all tempates on TMS to use IP instead of FQDN hoping to fix the issue.  The problem is the IPs I enter manually on the codec revert back to the FQDN at some point, I'm not sure where this is coming from.  I'm hoping someone can shed some light on that.

The last issue is that the touch panels seem normal to touch, however not only is the directory empty the self view and camera controls do not work.  If you try to make a call, a message is displayed saying the call can't be placed.  The touch panel still thinks it's paired to the codec and vice versa.  If you unpair it using the menu on the touch panel and use a remote control, the codec works perfectly.  Repair it and you're back to not working.  We have added a second account to these codecs for use with pairing the remote so that we don't have to give users our administrator password.  The account was given Admin and User roles, this has been working fine.  Now, seemingly out of the blue I had to add the audti role to this account in order to solve the last issue.  Without that role, the touch panel would pair but would be in the same state I just described.  Once the audit is added it works.

If anyone can shed any light on any of these issues I'd be very greatful!


Thanks,

Cody              

2 REPLIES 2
Magnus Ohm
Cisco Employee

Hi

I guess you are using DHCP for your endpoints which can make it hard for TMS to keep track of the system, what is the TMS tracking the system by? IP/MAC/Hostname?

You see that the phonebooks / external manager uses FQDN, this address is coming from the TMS and its the address you have typed in the "Network settings" in TMS. if you remove the FQDN and only leave the IP TMS will push the IP only. FQDN is preffered so if that is typed in then that is the address TMS will set.

This might be related to your phonebook issue if the endpoints cannot resolve the FQDN the phonebook will dissappear . TMS pushes these address every now and then on a fixed interval.

The last touch issue you have someone else might have a good answer to that.

/Magnus

Hi Magnus,

We are using DHCP and tracking in TMS by MAC.  Just to note, we are only seeing this issue on C series endpoints, MXP endpoints are behaving normally.

I do have the FQDN field set, I will remove it over the weekend to see if the helps resolve our issues.  Why is FQDN preferred?  All of my endpoints should be able to resolve the FQDN, is there a way to do a NSLOOKUP from an endpoint?  I'd like to try that during on a codec that isn't working.

I do believe this is all realated so I hope removing the FQDN helps!

Thanks for your response!

Content for Community-Ad

Spotlight Awards 2021