Showing results for 
Search instead for 
Did you mean: 

2 Unity Connection 8 questions


1)  When I try to assign an owner to a Call Handler, I do not see a way of assigning a System Distribution List as the owner.  Is this not possible?

2)  When I assign a person the role of User Administrator, it says they have permission to view user reports.  They do not have access to the Connection Servicability page, so how can they view user reports?

9 Replies 9

David Hailey

1) Unity Connection does not support the owner of a Call Handler being a Distribution List.

2) In general, you should not apply administrative roles outside of the Greetings Administrator role to users w/mailbox accounts.  In fact, in your scenario - I verified the behavior and found that when you do this, the user cannot login to CU Service.  However, if you give the user an administrative account (user without mailbox) and assign the same rights there are no issues.  The best practice outlined in the SRND and admin guide is to give administrators a separate non-mailbox account - you can have as many admin accounts as you want, they do not count against your licensed user count.


Please rate helpful posts!

Thanks for the quick reply.  Can you tell me where you see that owners of call handlers in Unity Connection can't be d-lists?  Here is an except of the System Administration Guide for Cisco Unity Connection Release 8.x:

"The Cisco Unity Greetings Administrator allows you—or the call handler owners that you assign—to manage call handler greetings from any phone. The owner of the call handler can be any user or system distribution list. "

Also, I tried creating a non-mailbox administrator user to create Call Handlers and manage User Accounts.  I have just the two roles for this user: Audio Text Administrator and User Administrator.  With those two roles, the user cannot login to Cisco Unity Connection Servicability.  Please note, that I removed System Administrator from the role for this user because I didn't want them to have full admin permissions.  Am I missing something?



Unless something has changed in 8x, then the CUGA is a typo or a copy/paste from Unity documentation. In migrating from Unity to CUC, one of the considerations is that a CH owner cannot be a distribution list. Instead, you specify the individual owners.

I tested on 7x without issue and only the User Administrator assigned. Do you have a non-default Administrator Template defined...and if not, did you ensure that you reset the default web application password for the user template and are you using that value when you attempt to login? Can you login to CU Admin first (may be forced to change password) and then navigate to CU Service?


Sent from my iPhone

I have not changed the Administrator template (although I removed the System Administrator role after creating the user as that seemed overkill).  I am able to login to CU Admin, but when changing to CU Servicabililty, the login screen comes back up and does not allow login with that same username/password.  Have I run into a bug in 8.x?  I guess I can report to Cisco if you think it should work with what I am doing.


Give me an example of the following:

Administrative account user alias (no mailbox)

Standard account user alias (mailbox)

I'm not sure what you mean by give you an example.  But here are the two alias' I have tried:

CHAdmin - is the no-mailbox adminstrative account.  It can log into CU Administration, but not into CU Servicability

BSole - is the mailbox account I originally tried with the same roles as CHAdmin and the same result.

When I try to log in, if I use an incorrect password, I get bad username or password error.  When I use the correct password, it just comes back to the login screen with no error.

I'd peruse the bug toolkit on Cisco and then open a TAC case. I have intermittent success with this today. The user I created yesterday was broken when I added the Audio Text role to the account. Likewise, I created a new account with both roles assigned and that user does not work either. Definitely odd behavior.

Thanks so much for looking into this and working to recreate the problem!  I find it odd behavior too.  I will open a ticket.  Just to add a note, when I look at the privileges of the User Administrator role, it does not include access to Servicability, whereas other roles that do reporting have that privilege.  But I am also unble to add roles or change the privileges in roles which I find strange too.  I hope moving to Unity Connection 8 isn't a mistake!  Thanks again for your time!

Hi Jill,

I'll look into getting the CUGA text corrected to remove the mention of system distribution lists as owners.

Thanks for bringing this to our attention.



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers