cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1377
Views
0
Helpful
3
Replies

COBRAS Export Unity Connections 11.5.1 Fails

dnelson
Beginner
Beginner

Trying to use latest version of  COBRAS Export to export messages from CUC 11.5.1.  Im getting the error:  Tried restarting IMAP server, disabling LDAP Authentication.  Verified that account has remote admin and Message account delegation roles.  Even tried a mailbox user account using same roles without luck

Nothing works.  Even tried Message Archiver Utility with same error.  Done this on CUC 11.x or below without issues.  Bug Search tool doesn't seem to have anything Similiar.  

Any Help would be appreciated.


[Thread 001], [16/10/31 12:53:48], (error) Failed establishing IMAP connection for message backup. Client error=Failed to connect to Connection mailstore with super user IMAP access in AttachViaImap. IMAP Client error=ChilkatLog:
Login:
DllDate: Jun 13 2016
ChilkatVersion: 9.5.0.58
UnlockPrefix: LNDBRGIMAPMAILQ
Architecture: Little Endian; 32-bit
Language: .NET 4.0
VerboseLogging: 0
login: wadmin
greeting: * OK UMSS IMAP4rev1 Server Completed

authenticateLogin:
loginImap:
ConnectionType: Unencrypted TCP/IP
--loginImap
isOK:
serverResponse: aaab NO Logon failure: unknown user or incorrect password
--isOK
--authenticateLogin
Failed.
--Login
--ChilkatLog

[Thread 001], [16/10/31 12:53:49], Unable to log into Connection to extract messages. Review the output below and the help file for details and troubleshooting steps.

3 Replies 3

lindborg
Cisco Employee
Cisco Employee

the most common issue I see here is someone trying to backup messages when they're running the unrestricted version of Unity Connection - the unrestricted version explicitly does not support secure IMAP connections required for COBRAS to be able to log in with super-user access to get messages for all users.

if you're running the unrestricted version you can use the "/useCUMI" command line option to instead extract messages via REST instead of IMAP - slower but you don't have another option if that's your situation.

if not then be sure the IMAP service is started on your Connection server (it should be running but I've seen cases where it's not).

Definitely not using the unrestricted Version.  

I tried the /useCUMI switch and that failed too.  The error on that was that the user didn't have the Mailbox Delegation role.  But the user (an actual mailbox user) did have both the remote administrator and mailbox delegate roles.

I do have LDAP authentication enabled.  So I tried disabling that and restarting DirSync and IMAP services.  Still Failing.  I haven't tried rebooting VM yet.  That is my next option.  Unless you can think of anything else.

definitely sounds like something not happy on the server side - COBRAS is just making a simple check for the presence of the mailbox access delegate role - not a lot of reasons that would get confused - this gets used in a number of tools (Message Archiver, Message Hunter, COBRAS, Message Shuttle etc...) - really basic query for that - if it's coming back false something is hosed up on the server side - hard to say what that would be right off hand.

that combined with the IMAP login failing would tend to imply the Connection server is in a bad state that probably needs some TAC eyeballs on it.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: