Showing results for 
Search instead for 
Did you mean: 
Field Notice 70545

Cisco UCS Platform Emulator 3.2(3ePE1)


Cisco UCS Platform Emulator, Release 3.2(3ePE1)


CONFIGURATION IMPORT NOTE:  Importing configuration backups (All, System, or Logical) taken from the UCS Platform Emulator (UCSPE) to physical UCS Manager domains is not recommended or supported by Cisco TAC.  UCSPE backups should only be imported to UCSPE domains.


New Features and Significant Changes in Cisco UCS PE, Release 3.2(3ePE1)

  • Full scale emulation of UCS Manager 3.2(3e) which supports M5 Hardware.  Note that there are limited functional changes from the previous release and not all features present in UCS Manager 3.2(3e) are supported (see Known Limitations).
  • New default HW config with M5 servers added.
    • Additional example Hardware configurations have been attached below.  The attached UCSPE configs can be imported from the UCSPE Equipment page.
  • UCSPE is featured in a Cisco dCloud programmability demo.   The demo includes a comprehensive lab guide including the following content for the Cisco UCS PowerTool and Python SDK:
    • Overviews of PowerShell and Python programming environments with step-by-step usage instructions
    • Code generation examples including code generation with UCS Manager's HTML5 interface
    • Sample script creation and use with UCSPE

Hardware Feature Summary

Please see the Release Notes for a complete list of supported Hardware.  Below is a summary:

  • M5 and M4 B-Series and C-Series servers including HX220C and HX240C
  • Cisco UCS S3260 chassis, servers, and storage controllers
  • NVMe-based PCIe storage options

Known Limitations

  • The Platform Emulator does not support connections to Cisco Intersight to avoid the use of Intersight resources by emulated devices. The Intersight Device Connector has been disabled and the device connector menu in the UI is non-functional. You can use Intersight demo environments in the Cisco demo Cloud ( ) and Cisco DevNet ( ) to explore the Intersight management of UCS.
  • Imported configurations should be manually checked to ensure there are no missing or unsupported components.  If issues are experienced following an import, any unsupported components can be manually deleted and missing components manually added through the Equipment menu on the Navigation pane.
  • Firmware Management and Firmware Auto Install have not been fully validated in this release.
    • If issues are experienced during FW download, please try alternate methods such as API based download (e.g., using PowerTool or Python SDK).
    • If issues are experienced with FW policies, please try excluding all components from the policy.
  • AAA-based authentication (LDAP, RADIUS, TACACs)— The Platform Emulator accepts security configuration changes, but does not enforce local or remote password authentication.  Any username and password combination can successfully log into the Cisco UCS Manger UI with administrator privileges.
  • See the Release Notes for the complete list of Known Limitations.


  • The Platform Emulator does not save UCSM configuration state across Emulator resets (to avoid consistency issues in UCSM configuration and the emulator HW configuration).  To preserve UCSM state, UCSM backup and import operations can be performed.  See an example backup/import flow here: PythonSDK for backup/restore (import) of UCSM config

Firmware Management: UCS PE supports uploading B-Series and C-Series server firmware bundles.  Because of the large file sizes of the firmware bundles, UCS PE only supports uploading of stripped-down versions (link below).  Stripped-down versions include only the firmware metadata (not the actual firmware binaries).

Download Instructions

MD5 hashes for downloads:

  • ZIP: 4B409EB4046354BA333A3AD4BFC4F15F
  • OVA: 587B64E769546E6069E9318D66968FFE
Frequent Contributor



3.2.(3e) backup does not seem to work. I let it run for an hour and it just hangs. No xml file is ever created and I am never returned back to UCSM.


Are there logs I can review?



Cisco Employee
I’ve duplicaed the issues with config backups through the UI. The team is investigating now. Backups are working through the API and PowerTool or Python can be used to perform a backup. An overview of the backup using Python is at

Thank you for looking into this.


I was able to workaround this issue by changing my browser, Chrome, "Automatic downloads" setting to prompt for a download location.


While on the "Backup Configuration" page, as the backup was supposed to be taking place, I did a Ctrl+Shift+J for the Chrome console and saw what looked to be permissions errors .... if that helps.







I am trying to get UCSPE up and running but I keep running into an error. I am getting network interfaces failed. I've tried auto, custom, and dhcp. I cannot geting the IPs up and running. Can someone help me troublethoo this ... thanks



You will have to give us specific details where it is failing. Are you performing the initial config?
Cisco Employee


Mohammed Hasaballa
Cisco Employee

using ucspe/ucspe to login and having a problem 

also, there is another error "unable to fetch domain"

any help greatly appreciated . thanks in advance

UCSPE_3.2.3e login error.PNG


Any idea when a 4.x version will be out?


Is it possible to configure the UCSPE for a demo Hyperflex deployment using the HX-Installer ova? I have configured the UCSPE with HX-NODES using HX templates and after running the HX Installer, it complains about RAID Controllers the Templates are using, are not supported. Before I try to figure this out, I wanted to see if its even supported or would work.


Hi Guys I have donwloaed the OVA twice and I am trying to set it up the first error i get it around CPU unsupported i am running a I7 8750h. Is this supported ?


Once it all loaded and services show up I am unable to get to the UI from all three of the ip addresses?


I have tried chrome, firefox and edge can you advise ?






Edit this was resolved with clearing the cache in google. 


According to this Cisco video I should be able to add a S3260 using a template. That is not working. Nothing happens when I select a template + Add; just like in the video. No device is added to the Chassis table. No errors. Just nothing. I have added a 5108+B200M5+C220 devices successfully.


UCSPE 3.2(3e)




Your work on these platforms are very much appreciated! Thank you for continuing to release new updates, hopefully it continues!


 It seems that both links on box for the .ova and .zip have been removed:


This shared file or folder link has been removed or is unavailable to you.

Will these come back up again, or can you advise of updated URLs ? - many thanks.

Cisco Employee
Cisco Employee


The page has been updated and the links should be working now, please try the download again.

Recognize Your Peers
Content for Community-Ad