02-19-2011 11:23 AM
Hi all,
How do i configure access-lists to allow voip traffic and block all other traffic. I've tried a few access-lists but none seem to be working here is my config
Current configuration : 2748 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R877W
!
boot-start-marker
boot-end-marker
!
logging buffered 4096
no logging console
no logging monitor
enable password 7 01100F175804
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid Cisco
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7 1510070D072123253F38667446
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
domain-name HomeLan
dns-server 212.77.192.59 212.77.192.60
!
ip dhcp pool Wlan
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
dns-server 212.77.192.59 212.77.192.60
domain-name WLAN
!
!
!
!
!
username admin privilege 15 password 7 104D000A0618
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
interface Loopback0
no ip address
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
encryption mode ciphers tkip
!
ssid Cisco
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
channel 2447
station-role root
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
ip address negotiated
ip access-group vlan1-block in
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
ppp authentication pap chap callin
ppp chap hostname s4860348
ppp chap password 7 08304D5A080B5445
ppp pap sent-username s4860348 password 7 095D4F1D18174640
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip http authentication local
no ip http secure-server
ip nat inside source list 10 interface Dialer1 overload
!
ip access-list extended vlan1-block
permit udp host 77.72.169.134 eq 5060 host 192.168.1.254 log
deny udp any gt 1024 any log
deny tcp any gt 1024 any log
deny igmp any any
deny icmp any any echo
permit ip any any
!
logging source-interface Loopback0
logging 192.168.10.40
access-list 10 permit any
arp 192.168.10.40 0021.5c6c.ab49 ARPA
!
!
!
control-plane
!
banner motd ^C
********** HOME ADSL ROUTER **************
****** UNAUTHORISED ACCESS PROHIBITED **** ^C
!
line con 0
login local
no modem enable
line aux 0
password 7 14160713
login
line vty 0 4
password 7 120D001B1C0E18
login
!
scheduler max-task-time 5000
end
Thanks in advance.
Solved! Go to Solution.
03-10-2011 04:13 PM
Hello,
mh... you only allow SIP (Signaling) but no RTP.
permit udp host 77.72.169.134 eq 5060 host 192.168.1.254 log
permit udp host 77.72.169.134 range 16384 32767 host 192.168.1.254 log
deny udp any gt 1024 any log
deny tcp any gt 1024 any log
deny igmp any any
deny icmp any any echo
permit ip any any
Kind regards,
Marcel Ammann
P.S.: Please rate helpful post's
03-10-2011 04:13 PM
Hello,
mh... you only allow SIP (Signaling) but no RTP.
permit udp host 77.72.169.134 eq 5060 host 192.168.1.254 log
permit udp host 77.72.169.134 range 16384 32767 host 192.168.1.254 log
deny udp any gt 1024 any log
deny tcp any gt 1024 any log
deny igmp any any
deny icmp any any echo
permit ip any any
Kind regards,
Marcel Ammann
P.S.: Please rate helpful post's
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide