cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
806
Views
0
Helpful
3
Replies

Mitel 5360 IP Phones on Cisco 4506E

I need to connect up to 30 Mitel 5360 IP Phones to an existing Cisco 4506E with WS-X45-SUP6-E installed.

They will all be connected to WS-X4548-RJ45V+ 

Does anyone have a recommended configuration example?

Looks like this version "12.2(50)SG" of IOS has no "mls qos" command.

Any help greatly appreciated.

3 Replies 3

chrihussey
VIP Alumni
VIP Alumni

I have a 6L-E, so if they are the same:

Don't know about the Mitel phones, but for starters if they don't do CDP, you may need to have to enable LLDP if you are using a voice VLAN.

As far as QoS is concerned, you should be able to configure auto qos. In interface configuration mode try the "auto qos voip trust" command. It will auto generate a lot of policies and add configurations to the interface.

The other choice would be to configure your own policies and apply that to the interfaces. Here's an example:

!
class-map match-any NET-MGMT-SIG
  match  dscp cs7
  match  dscp cs6
  match  dscp cs3
  match  dscp cs2
class-map match-any PRIORITY
  match  dscp ef
  match  dscp cs4
class-map match-any VIDEO-CONF
  match  dscp af41
!
policy-map QOS-POLICY
 class PRIORITY
    priority
    police cir percent 30 bc 33 ms
      conform-action transmit
      exceed-action drop
 class NET-MGMT-SIG
    bandwidth percent 10
 class VIDEO-CONF
    bandwidth percent 10
 class class-default
    bandwidth percent 50
    dbl
!

Then apply this as an outbound on the interfaces as well as inbound trust:

!
interface GigabitEthernet3/1
 service-policy output QOS-POLICY

 qos trust extend
!

Mind you, this is of course the Mitel phones are using the standard markings for voice (EF) and voice signaling (CS3). If otherwise adjust accordingly.

Hope this helps.

Thanks. Looks like Mitel phones support CDP. Yes I used auto qos.

Below is what I currently have as a config. When the phones arrive, I will test and look for the standard markings (EF) and signaling.

-----------------------------------------

class-map match-all AutoQos-VoIP-Control-Dscp26

match  dscp af31

class-map match-all AutoQos-VoIP-Control-Dscp24

match  dscp cs3

class-map match-all AutoQos-VoIP-Bearer-Cos

match cos  5

class-map match-all AutoQos-VoIP-Control-QosGroup24

match qos-group 24

class-map match-all AutoQos-VoIP-Control-QosGroup26

match qos-group 26

class-map match-all AutoQos-VoIP-Bearer-QosGroup

match qos-group 46

class-map match-all AutoQos-VoIP-Bearer-Dscp

match  dscp ef

class-map match-all AutoQos-VoIP-Control-Cos

match cos  3

!

!

policy-map AutoQos-VoIP-Input-Dscp-Policy

class AutoQos-VoIP-Bearer-Dscp

  set qos-group 46

class AutoQos-VoIP-Control-Dscp26

  set qos-group 26

class AutoQos-VoIP-Control-Dscp24

  set qos-group 24

policy-map AutoQos-VoIP-Input-Cos-Policy

class AutoQos-VoIP-Bearer-Cos

  set qos-group 46

class AutoQos-VoIP-Control-Cos

  set qos-group 24

policy-map AutoQos-VoIP-Output-Policy

class AutoQos-VoIP-Bearer-QosGroup

  set dscp ef

  set cos 5

    priority

    police cir percent 33

class AutoQos-VoIP-Control-QosGroup26

  set dscp af31

  set cos 3

    bandwidth remaining percent 5

class AutoQos-VoIP-Control-QosGroup24

  set dscp cs3

  set cos 3

    bandwidth remaining percent 5

class class-default

    dbl

interface GigabitEthernet3/1

switchport access vlan 12

switchport voice vlan 13

switchport priority extend trust

auto qos voip trust

qos trust extend

spanning-tree portfast

service-policy input AutoQos-VoIP-Input-Cos-Policy

service-policy output AutoQos-VoIP-Output-Policy

Yep. You should be in good shape. Good luck.