01-07-2013 01:22 AM
Hi all
I have question regarding implementation of QoS on logical interface. I tried to search for the answer if it is even possible, but all I could find was that it is not because logical interface handles queuing and shaping differently than typical L3 port.
Lets say that I have router with 1 wan port DSL used as backup and four L2 switchports, where 3 of them are LAN ports (vlan10) and last is used as primary WAN uplink (vlan20).
I would like to set QoS on interface vlan 20 to prioritize voice, is ti possible and if not why?
Can somebody explain or suggest some documents to study.
Thanks
Solved! Go to Solution.
01-09-2013 05:52 AM
What router and IOS version are you using ?
Can you turn Fa0/0 into a layer 3 port by issuing the no switchport command ?
If you can, then you can assign the IP to Fa0/0 and have better QOS options availble.
You need to apply a service policy that assigns the DSCP markings in the inbound direction on VLAN 10. You will run into a problem when applying a policy in the outbound direction on vlan 20 that queues and prioritizes traffic and will give you a configuration failed error as SVIs do not usually support CBWFQ and LLQ
Lets first see if Fa0/0 can be a routed port and take it from there
Are you familar with creating class-maps and policy-maps or would you like some examples ?
01-09-2013 01:53 AM
For QOS on DSL, apply the QOS in the ATM virtual circuit
Check the upstream sync speed ( show dsl int atm [number] ) and create a parent policy map to shape to an average of that speed and nest the actual policy inside
example :
policy-map CHILD
class VOIP-MATCH
priority 128
policy-map PARENT
class class-default
shape average 512000
service-policy CHILD
interface ATM0.1 point-to-point
pvc 8/35
vbr-rt 512 512
tx-ring-limit 3
service-policy output PARENT
pppoe-client dial-pool-number 1
tx-ring-limit 3 shortens the hardware queue to allow the layer-3 queue to kick in sooner. Service policies only apply to packets in the layer-3 queues. The default vaule is 16, I find 3 works perfectly in my environment, but you can test with different vaules.
I use this method on 877s and 1841s with ADSL WICs and it works well. Use qos pre-classify if you're tunneling over it.
What type of WAN link are you using on vlan 20 ?
01-09-2013 05:20 AM
Hi, thanks for answer
primary link is Ethernet connection to some ISP.
vlan 20
name WAN_UPLINK
Fa0/0
switchport mode access
switchport access vlan 20
int vlan 20
ip add 192.168.0.2 255.255.255.252
ip route 0.0.0.0 0.0.0.0 vlan 20 192.168.0.1
01-09-2013 05:52 AM
What router and IOS version are you using ?
Can you turn Fa0/0 into a layer 3 port by issuing the no switchport command ?
If you can, then you can assign the IP to Fa0/0 and have better QOS options availble.
You need to apply a service policy that assigns the DSCP markings in the inbound direction on VLAN 10. You will run into a problem when applying a policy in the outbound direction on vlan 20 that queues and prioritizes traffic and will give you a configuration failed error as SVIs do not usually support CBWFQ and LLQ
Lets first see if Fa0/0 can be a routed port and take it from there
Are you familar with creating class-maps and policy-maps or would you like some examples ?
01-09-2013 11:06 AM
Let's say that I have cisco 866, it has 4 fastethernet ports (Fa0-3) and 1 gigabitethernet port Gi0, which can not become routed ports and have own IP address. And port Gi1 which is WAN port operating ether in dsl or ethernet mode.
I used Gi1 for DSL link -> it is supposed to be backup link.
Port Gi0 is used as primary WAN port:
Gi0
switchport mode access
switchport access vlan 20
int vlan 20
ip add 192.168.0.2 255.255.255.252
And now I would like to implement QoS for voice traffic on Vlan20 port.
I am familiar with QoS configuration and alghorithm how it works but I do not know how it really physically work, what is supported and what is not.
I am very thankful for information which you provided so far, I do not expect you to teach me or explain everything from basics. But maybe advise some site/book/document to read. Everything what I found so far was configuration of class/policy maps, there is plenty of this. For example, I did not find any information that SVI do not support policy in outbound....
01-10-2013 05:55 AM
I think you can create a QoS policy as you already know and apply the service policy to the gig0 port in the out direction.
A QoS policy doesn't need to be applied to a L3 port
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide