cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
208
Views
0
Helpful
0
Replies
huihuxu735715
Beginner

The voice gateway configuration of the C4300 is replaced

Our company has changed the calling service of the new carrier, which configurations should I modify  


!
subscriber templating
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
trunk group 1
!
!
!
!
!
voice service voip
address-hiding
media disable-detailed-stats
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip handle-replaces
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
bind control source-interface GigabitEthernet0/0/0
registrar server
asymmetric payload full
video screening
!
voice class codec 1
codec preference 1 g711alaw
codec preference 3 g729r8
!
!
!
!
!
voice register global
mode cme
source-address 10.14.199.10 port 5060
max-dn 200
max-pool 110
authenticate register
timezone 42
time-format 24
tftp-path flash:
create profile sync 0007022550030434
!
voice register dn 1
!
voice register dn 2
!
voice register dn 3
number 8013
!
voice register dn 5
!
voice register dn 6
number 8004
!
voice register dn 7
number 8818
!
voice register dn 8
number 8807
!
voice register dn 9
number 8010
!
voice register dn 10
number 8805
!
voice register dn 11
number 8001
!
voice register dn 12
number 8015
!
voice register dn 13
number 8823
!
voice register dn 14
number 8913
!
voice register dn 15
number 8819
!
voice register dn 16
number 8927
!
voice register dn 17
number 8821
!
voice register dn 18
number 8817
!
voice register dn 19
number 8939
!
voice register dn 20
number 8815
!
voice register dn 21
number 8006
!
voice register dn 22
number 8003
!
voice register dn 23
number 8936
!
voice register dn 24
number 8008
!
voice register dn 25
number 8806
!
voice register dn 26
number 8937
!
voice register dn 27
number 8011
!
voice register dn 28
number 8935
!
voice register dn 29
number 8970
!
voice register dn 30
number 8820
!
voice register dn 31
number 8810
!
voice register dn 32
number 8813
!
voice register dn 33
number 8812
!
voice register dn 34
number 8933
!
voice register dn 35
number 8007
!
voice register dn 36
number 8014
!
voice register dn 37
number 8809
!
voice register dn 38
number 8816
!
voice register dn 39
number 8826
!
voice register dn 40
number 8920
!
voice register dn 41
number 8002
!
voice register dn 42
number 8932
!
voice register dn 43
number 8005
!
voice register dn 44
number 8009
!
voice register pool 1
busy-trigger-per-button 2
id mac B4A8.B94C.0CF0
session-transport tcp
type 7821
dtmf-relay rtp-nte
username sip001 password cisco
codec g711ulaw
no vad
!
voice register pool 2
busy-trigger-per-button 2
!
voice register pool 3
busy-trigger-per-button 2
id mac 2852.61C4.333B
type 3905
number 1 dn 3
dtmf-relay rtp-nte
username sip003 password cisco
codec g711ulaw
no vad
!
voice register pool 5
busy-trigger-per-button 2
id mac B4A8.B94C.3C40
session-transport tcp
type 7821
dtmf-relay rtp-nte
username sip005 password cisco
codec g711ulaw
no vad
!
voice register pool 6
busy-trigger-per-button 2
id mac E089.9D94.9D32
type 3905
number 1 dn 6
dtmf-relay rtp-nte
username sip006 password cisco
codec g711ulaw
no vad
!
voice register pool 7
busy-trigger-per-button 2
id mac B07D.47C1.49ED
type 3905
number 1 dn 7
dtmf-relay rtp-nte
username sip007 password cisco
codec g711ulaw
no vad
!
voice register pool 8
busy-trigger-per-button 2
id mac DCEB.94BC.8C3D
type 3905
number 1 dn 8
dtmf-relay rtp-nte
username sip008 password cisco
codec g711ulaw
no vad
!
voice register pool 9
busy-trigger-per-button 2
id mac 2852.61C4.32CF
type 3905
number 1 dn 9
dtmf-relay rtp-nte
username sip009 password cisco
codec g711ulaw
no vad
!
voice register pool 10
busy-trigger-per-button 2
id mac F078.16A3.7255
type 3905
number 1 dn 10
dtmf-relay rtp-nte
username sip010 password cisco
codec g711ulaw
no vad
!
voice register pool 11
busy-trigger-per-button 2
id mac E089.9D94.9E5E
type 3905
number 1 dn 11
dtmf-relay rtp-nte
username sip011 password cisco
codec g711ulaw
no vad
!
voice register pool 12
busy-trigger-per-button 2
id mac 2852.61C4.3319
type 3905
number 1 dn 12
dtmf-relay rtp-nte
username sip012 password cisco
codec g711ulaw
no vad
!
voice register pool 13
busy-trigger-per-button 2
id mac DCEB.94BC.8BB0
type 3905
number 1 dn 13
dtmf-relay rtp-nte
username sip013 password cisco
codec g711ulaw
no vad
!
voice register pool 14
busy-trigger-per-button 2
id mac BC67.1CDD.CD99
type 3905
number 1 dn 14
dtmf-relay rtp-nte
username sip014 password cisco
codec g711ulaw
no vad
!
voice register pool 15
busy-trigger-per-button 2
id mac 3CCE.7358.EC1F
type 3905
number 1 dn 15
dtmf-relay rtp-nte
username sip015 password cisco
codec g711ulaw
no vad
!
voice register pool 16
busy-trigger-per-button 2
id mac 0008.2FB6.405D
type 3905
number 1 dn 16
dtmf-relay rtp-nte
username sip016 password cisco
codec g711ulaw
no vad
!
voice register pool 17
busy-trigger-per-button 2
id mac DCEB.94BC.8BD0
type 3905
number 1 dn 17
dtmf-relay rtp-nte
username sip017 password cisco
codec g711ulaw
no vad
!
voice register pool 18
busy-trigger-per-button 2
id mac F078.16A3.7159
type 3905
number 1 dn 18
dtmf-relay rtp-nte
username sip018 password cisco
codec g711ulaw
no vad
!
voice register pool 19
busy-trigger-per-button 2
id mac BC67.1CDC.D6DB
type 3905
number 1 dn 19
dtmf-relay rtp-nte
username sip019 password cisco
codec g711ulaw
no vad
!
voice register pool 20
busy-trigger-per-button 2
id mac F078.16A3.722D
type 3905
number 1 dn 20
dtmf-relay rtp-nte
username sip020 password cisco
codec g711ulaw
no vad
!
voice register pool 21
busy-trigger-per-button 2
id mac 2C0B.E905.DD8A
type 3905
number 1 dn 21
dtmf-relay rtp-nte
username sip021 password cisco
codec g711ulaw
no vad
!
voice register pool 22
busy-trigger-per-button 2
id mac E089.9D94.9DD1
type 3905
number 1 dn 22
dtmf-relay rtp-nte
username sip022 password cisco
codec g711ulaw
no vad
!
voice register pool 23
busy-trigger-per-button 2
id mac BC67.1CDD.09E8
type 3905
number 1 dn 23
dtmf-relay rtp-nte
username sip023 password cisco
codec g711ulaw
no vad
!
voice register pool 24
busy-trigger-per-button 2
id mac 2852.61C4.3720
type 3905
number 1 dn 24
dtmf-relay rtp-nte
username sip024 password cisco
codec g711ulaw
no vad
!
voice register pool 25
busy-trigger-per-button 2
id mac F078.16A3.37C1
type 3905
number 1 dn 25
dtmf-relay rtp-nte
username sip025 password cisco
codec g711ulaw
no vad
!
voice register pool 26
busy-trigger-per-button 2
id mac BC67.1CDD.CE6B
type 3905
number 1 dn 26
dtmf-relay rtp-nte
username sip026 password cisco
codec g711ulaw
no vad
!
voice register pool 27
busy-trigger-per-button 2
id mac 2852.61C4.30CA
type 3905
number 1 dn 27
dtmf-relay rtp-nte
username sip027 password cisco
codec g711ulaw
no vad
!
voice register pool 28
busy-trigger-per-button 2
id mac BC67.1CDD.D128
type 3905
number 1 dn 28
dtmf-relay rtp-nte
username sip028 password cisco
codec g711ulaw
no vad
!
voice register pool 29
busy-trigger-per-button 2
id mac 0008.2FB6.1644
type 3905
number 1 dn 29
dtmf-relay rtp-nte
username sip029 password cisco
codec g711ulaw
no vad
!
voice register pool 30
busy-trigger-per-button 2
id mac B07D.47C1.50F7
type 3905
number 1 dn 30
dtmf-relay rtp-nte
username sip030 password cisco
codec g711ulaw
no vad
!
voice register pool 31
busy-trigger-per-button 2
id mac B07D.47C1.4515
type 3905
number 1 dn 31
dtmf-relay rtp-nte
username sip031 password cisco
codec g711ulaw
no vad
!
voice register pool 32
busy-trigger-per-button 2
id mac F078.16A3.71F8
type 3905
number 1 dn 32
dtmf-relay rtp-nte
username sip032 password cisco
codec g711ulaw
no vad
!
voice register pool 33
busy-trigger-per-button 2
id mac F078.16A3.7168
type 3905
number 1 dn 33
dtmf-relay rtp-nte
username sip033 password cisco
codec g711ulaw
no vad
!
voice register pool 34
busy-trigger-per-button 2
id mac 0008.2FB6.176D
type 3905
number 1 dn 34
dtmf-relay rtp-nte
username sip034 password cisco
codec g711ulaw
no vad
!
voice register pool 35
busy-trigger-per-button 2
id mac 2852.61C4.332E
type 3905
number 1 dn 35
dtmf-relay rtp-nte
username sip035 password cisco
codec g711ulaw
no vad
!
voice register pool 36
busy-trigger-per-button 2
id mac 2852.61C4.303F
type 3905
number 1 dn 36
dtmf-relay rtp-nte
username sip036 password cisco
codec g711ulaw
no vad
!
voice register pool 37
busy-trigger-per-button 2
id mac B07D.47C1.4D0B
type 3905
number 1 dn 37
dtmf-relay rtp-nte
username sip037 password cisco
codec g711ulaw
no vad
!
voice register pool 38
busy-trigger-per-button 2
id mac B07D.47C1.473C
type 3905
number 1 dn 38
dtmf-relay rtp-nte
username sip038 password cisco
codec g711ulaw
no vad
!
voice register pool 39
busy-trigger-per-button 2
id mac B07D.47C1.50FA
type 3905
number 1 dn 39
dtmf-relay rtp-nte
username sip039 password cisco
codec g711ulaw
no vad
!
voice register pool 40
busy-trigger-per-button 2
id mac 0008.2FB6.1582
type 3905
number 1 dn 40
dtmf-relay rtp-nte
username sip040 password cisco
codec g711ulaw
no vad
!
voice register pool 41
busy-trigger-per-button 2
id mac E089.9D94.9F23
type 3905
dtmf-relay rtp-nte
username sip041 password cisco
codec g711ulaw
!
voice register pool 42
busy-trigger-per-button 2
id mac BC67.1CDC.D963
type 3905
number 1 dn 42
dtmf-relay rtp-nte
username sip042 password cisco
codec g711ulaw
no vad
!
voice register pool 43
busy-trigger-per-button 2
id mac E089.9D94.9DC7
type 3905
number 1 dn 43
dtmf-relay rtp-nte
username sip043 password cisco
codec g711ulaw
no vad
!
voice register pool 44
busy-trigger-per-button 2
id mac 2C0B.E905.E592
type 3905
number 1 dn 44
dtmf-relay rtp-nte
username sip044 password cisco
codec g711ulaw
no vad
!
!
voice translation-rule 1
rule 2 /8012/ /80889012/
rule 3 /8013/ /80889013/
rule 6 /8004/ /80889004/
rule 7 /8818/ /80889818/
rule 8 /8807/ /80889807/
rule 9 /8010/ /80889010/
rule 10 /8805/ /80889805/
rule 11 /8001/ /80889001/
rule 12 /8015/ /80889015/
rule 13 /8823/ /80889823/
rule 14 /8913/ /80888913/
rule 15 /8819/ /80889819/
rule 16 /8927/ /80888927/
rule 17 /8821/ /80889821/
rule 18 /8817/ /80889817/
rule 19 /8939/ /80888939/
rule 20 /8815/ /80889815/
rule 21 /8006/ /80889006/
rule 22 /8003/ /80889003/
rule 23 /8936/ /80888936/
rule 24 /8008/ /80889008/
rule 25 /8806/ /80889806/
rule 26 /8937/ /80888937/
rule 27 /8011/ /80889011/
rule 28 /8935/ /80888935/
rule 29 /8970/ /80888970/
rule 30 /8820/ /80889820/
rule 31 /8810/ /80889810/
rule 32 /8813/ /80889813/
rule 33 /8812/ /80889812/
rule 34 /8933/ /80888933/
rule 35 /8007/ /80889007/
rule 36 /8014/ /80889014/
rule 37 /8809/ /80889809/
rule 38 /8816/ /80889816/
rule 39 /8826/ /80889826/
rule 40 /8920/ /80888920/
rule 41 /8002/ /80889002/
rule 42 /8932/ /80888932/
rule 43 /8005/ /80889005/
rule 44 /8009/ /80889009/
!
voice translation-rule 2
rule 2 /80889012/ /8012/
rule 3 /80889013/ /8013/
rule 6 /80889004/ /8004/
rule 7 /80889818/ /8818/
rule 8 /80889807/ /8807/
rule 9 /80889010/ /8010/
rule 10 /80889805/ /8805/
rule 11 /80889001/ /8001/
rule 12 /80889015/ /8015/
rule 13 /80889823/ /8823/
rule 14 /80888913/ /8913/
rule 15 /80889819/ /8819/
rule 16 /80888927/ /8927/
rule 17 /80889821/ /8821/
rule 18 /80889817/ /8817/
rule 19 /80888939/ /8939/
rule 20 /80889815/ /8815/
rule 21 /80889006/ /8006/
rule 22 /80889003/ /8003/
rule 23 /80888936/ /8936/
rule 24 /80889008/ /8008/
rule 25 /80889806/ /8806/
rule 26 /80888937/ /8937/
rule 27 /80889011/ /8011/
rule 28 /80888935/ /8935/
rule 29 /80888970/ /8970/
rule 30 /80889820/ /8820/
rule 31 /80889810/ /8810/
rule 32 /80889813/ /8813/
rule 33 /80889812/ /8812/
rule 34 /80888933/ /8933/
rule 35 /80889007/ /8007/
rule 36 /80889014/ /8014/
rule 37 /80889809/ /8809/
rule 38 /80889816/ /8816/
rule 39 /80889826/ /8826/
rule 40 /80888920/ /8920/
rule 41 /80889002/ /8002/
rule 42 /80888932/ /8932/
rule 43 /80889005/ /8005/
rule 44 /80889009/ /8009/
!
!
voice translation-profile fr-pstn
translate called 2
!
voice translation-profile to-pstn
translate calling 1
!
!
!
!
voice-card 0/1
no watchdog
!
license udi pid ISR4331/K9 sn FDO21362MTB
!
spanning-tree extend system-id
!
username ciaco password 0 jsmaadmin@itservice
username cisco secret 5 $1$cHIt$mVK84/Czaj0uYuTRxo9lH.
!
redundancy
mode none
!
controller E1 0/1/0
framing no-crc4
pri-group timeslots 1-31
trunk-group 1 timeslots 1-31
!
controller E1 0/1/1
framing no-crc4
pri-group timeslots 1-31
trunk-group 1 timeslots 1-31
!
!
vlan internal allocation policy ascending
!
lldp run
!
!
!
!
!
interface GigabitEthernet0/0/0
ip address 10.14.199.10 255.255.255.0
negotiation auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.14.199.10
!
interface GigabitEthernet0/0/1
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet0/0/2
no ip address
shutdown
negotiation auto
!
interface Service-Engine0/1/0
!
interface Serial0/1/0:15
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
no cdp enable
!
interface Serial0/1/1:15
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn send-alerting
isdn sending-complete
no cdp enable
!
interface GigabitEthernet0
vrf forwarding Mgmt-intf
ip address 2.2.2.1 255.255.255.0
negotiation auto
!
interface Vlan1
no ip address
shutdown
!
ip default-gateway 10.14.199.254
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 10.14.199.254
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
!
!
!
!
control-plane
!
!
voice-port 0/1/0:15
mwi
cptone CN
timeouts call-disconnect 1
timeouts wait-release 10
bearer-cap Speech
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
telephony-service
max-conferences 8 gain -6
transfer-system full-consult
!
!
dial-peer voice 1 pots
translation-profile incoming fr-pstn
incoming called-number .
direct-inward-dial
!
dial-peer voice 9 pots
translation-profile outgoing to-pstn
destination-pattern 9[1-9]T
direct-inward-dial
port 0/1/0:15
!
dial-peer voice 90 pots
translation-profile outgoing to-pstn
destination-pattern 90[1-9]T
port 0/1/0:15
prefix 0
!
dial-peer voice 900 pots
destination-pattern 900T
port 0/1/0:15
prefix 00
!
!
gateway
timer receive-rtp 1200
!
sip-ua
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login local
transport input all
!
!
end

0 REPLIES 0