Showing results for 
Search instead for 
Did you mean: 

PPPoE on UC520 just never connects

Level 1
Level 1

Everything on my UC520 works perfectly except this!  We upgraded our Internet and got a Static IP.  The modem for the speed we have is a modem/router combo but can be used as a bridge.  I just have to have the Cisco do the PPPoE authentication.

We previously had it set for DHCP.  Last night I changed it in CCA to PPPoE, entered username and password and picked IP Negotation.  I'd apply, and no matter what I'd do Internet would never work.  I don't know where to go to check the logs or status message to see what it's doing or if it's even trying to connect.  So anyway I had enough and I formatted the system did a factory reset.  Doing the telephony setup wizard I picked PPPoE with IP Negotation and entered my username/password.  This time it worked immediately, connected and my WAN IP was my Static IP and it was great.  I thought maybe something was messed from all the iOS upgrades.

I then noticed today that Traffic Shaping was disabled, so I enabled it and applied.  Immediately the Internet went down.  I checked the status and showed everything was down.  I rebooted the UC520, same thing.  Reboot DSL modem same thing.  I disable Traffic Shaping, no Internet. Reboot UC520, reboot modem nothing.  I put it to DHCP then back to PPPoE, same issue as last night it just doesn't do anything, no IP no nothing.

Before I give back the UC520 and pack it in, is there anything else I can check?  I know everyone said the CIsco is really hard etc but I'm just frustrated because EVERYTHING works!!!  This is the only issue I have.  The reason we need PPPoE is because otherwise inbound DID calls don't work because I guess ports are closed going through another router.  Any suggestions?

3 Replies 3

paolo bevilacqua
Hall of Fame
Hall of Fame

You need the DSL router set in bridge mode for having PPPoE working on the UC500.

David Trad
VIP Alumni
VIP Alumni

Hi Lee,

If you know how to capture your running configuration it would be good if you could post it up to see if CCA applied the right settings, and to make sure nothing critical was altered to cause such a problem.

Please make sure that you remove any sensitive data from the configuration file, and you also upload it as a text file not a direct post to the thread.

Further to that can you advise on what type of modem you are using? Sometimes modems are reported as supporting Bridge Mode, but it is a different RFC bridge mode, and the modem still insists on acting as a router, which will no doubt cause a conflict with the UC-500.


David Trad.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

Level 1
Level 1

Well what I do know is that it's in Bridge mode according to Bell Canada.  Basically you hold reset on the bottom and it restarts.  That then makes it act as a router, but without the PPPoE link set up, so it will still assign IPs like with its IP being, its just missing username and password in the actual router which you're supposed to put in your 3rd party router.  If I set up PPPoE on Windows 7, it authenticates and works.  However if I disable DHCP in the modem and connect it to my laptop so that it never gets an IP, then PPPoE never works I noticed it always fails to connect.  I have to enable DHCP so that my laptop gets an IP like (which still directs me to the Bell gateway wanting me to set up my connection if I try to access google etc), but then I can use the Windows 7 dialer and connect to PPPoE.

The modem is a Sagemcom FAST 2864 and the technician told me as well that was how you put it in bridge mode and that I need to set up the Cisco to do the PPPoE authentication.  What confuses me though is that putting in the username/password did nothing for hours last night, was pulling my hair out.  Then I did a factory reset, and during the Telephony Setup wizard I picked PPPoE, entered username and password and it immediately worked.  It was only today when I enabled Traffic Shaping that caused it to drop and never reestablish.

I unfortunaely don't know how to capture the config file but I'm sure I could figure it out, just can't do that until tomorrow as I shut it all down and unplugged it all and switched back to Asterisk as we needed to be able to use the phones.  The thing I don't get though is that the only issue I have is that inbound DID calls fail, so it's like a port issue with the dual router.  However if I connect Asterisk to the Bell modem when it's in modem mode and not bridge mode, all DID calls work fine on it.  Only when the Cisco did the PPPoE authentication did my inbound DIDs work, otherwise I wouldn't care if it was just a device on the Bell modem/router.  DMZ does nothing though, but on the old 2wire modem we had, enabling DMZ fixed the issue since it didn't support bridge mode, but DMZ on the Sagem doesn't do anything.