cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
716
Views
0
Helpful
5
Replies

SPA504G phones failing to update Firmware

Kevin Pattison
Level 1
Level 1

I manage a small office with approx 12 SPA504Gs I have spent time setting up correct provisioning to ensure all phones get the latest updates and this works on most phones.

 

However there are 4 phones in the office that are stuck on an older version. I believe this may have happened because the firmware file was moved on the provisioning host while they were downloading it a few months ago. Now they download whatever new firmware file, reboot but they're still on 7.5.5b.

 

How can I diagnose/resolve the issue?

5 Replies 5

Dan Lukes
VIP Alumni
VIP Alumni

Catch phone's communication. It will reveal where the device are asking, the request they are issuing as well as server's response.

In the case the SSL is used tun on syslog&debug messages and catch them. They are not as good source of information as phone's communication itself, but in most case it allow to identify issue as well.


 

Dan,

Sorry, the problem is actually that the phones are not doing Firmware update calls at all! This is now happening with multiple versions including 7.5.6 (should be updating to 7.5.6a but not doing calls). They do calls for config updates but not for firmware.

Kevin

Well, it needs to be config issue. We update firmware of phones this way with no problem. But with neither configuration nor syslog&debug messages I'm unable to make hypothesis.

 

Dan,

 

I think you're right as none of my phones are doing firmware calls any more, however I can't see the problem. The provisioning calls for the XML files are working and the config page is attached. Can you see why they aren't doing Firmware calls?

No.

1. How you verified the phone doesn't call for firmware ?

2. Phone will not fetch the firmware if it has been fetched already in the past (e.g. as long as Upgrade_Rule is the same, the file will not be fetched second time). Just change it (you can replace SWVER with other version that the one the phone is running on) and try again.

 

You should catch the syslog and debug messages. They may disclose more.

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: