Showing results for 
Search instead for 
Did you mean: 

UC540 and NVG589 (AT&T U-Verse Modem)

Level 1
Level 1

This is a bit of a follow-up to the previous post of memory issues w/ the UC540.  I had (two weeks ago) changed the Internet connection from a Time Warner with Ubee modem to an AT&T connection with an NVG589.

I don't have a UC540 at my office, I use a Tomato-based router with a FreePBX (Asterisk) box.  I previously had Time Warner and it worked great, but about a year ago I switched to the AT&T U-Verse with NVG589 because I was able to get a 45x6 connection for about $90/month.  Time Warner was charging me about $175 for a 12x1.5 circuit.

For me, switching to the AT&T NVG589 required changing some settings in the NVG589 to supported static IP.  I got a range of five IP's and had to disable the firewall and some other settings on the NVG589 to make these work.  AT&T walked me through this process.  I then put my new static IP into my Tomato router and it worked fine, never missed a beat.

So when switching my friend with the UC540 over to the NVG589, I duplicated all the steps, reset the NAT stuff, redid the VPN stuff, and lit it up.  And it seemed to work fine for a week or two.  It was at that point (after a couple of weeks) that he started getting choppy voice, and then I found that after rebooting the UC540 and looking at the diagnostic page that all sorts of memory allocation/fragmentation issues were occuring.

So today I went out there and tried everything I could, and that UC540 just didn't want anything to do with the NVG589.  I finally switched back to the Time Warner circuit (good thing they still had it) and the UC540 settled right down.  No more griping about memory, nothing, working perfectly again.

So I'm wondering if anyone has any ideas?  I double-checked the setup of the NVG589, comparing it to mine, and I think I got everything setup correctly.

These NVG589 units don't operate in pure bridge mode.  Instead, they allow static IP while also continuing to serve as a router.  The UC540 is on and the NVG589 is on, so there shouldn't be any conflict.

Anyone is welcome to say anything, just wondering why it seemed to work for a few days and then went to heck.

1 Reply 1

Level 1
Level 1

Well things have been working just dandy on the Time Warner cable modem circuit.  Not a single hiccup.  Still don't know why the UC540 is rejecting the NVG589.  Any ideas?