Showing results for 
Search instead for 
Did you mean: 

Updating phone firmware - issues

Level 1
Level 1

Hi All,

I have a TAC case open, but since it's the weekend, not getting much response at the moment. That's fine. I just need some clarification on what I'm doing here.

This is what the TAC person has said:

For each file you must do the next:

Router#Copy tftp: flash:
Address or name of remote host []?        tftp address
Source filename []?       filename.XXX
Destination filename [filename.XXX]?      enter

Router(config)# tftp-server flash:    filename.XXX

To activate the new firmware you use the next command but only with the file that is  .loads and without the .loads extension:

Router(config)# telephony-service
Router(config-telephony)# load xxxxx  filename


Router(config-telephony)#no create cnf-files
Router(config-telephony)#create cnf-files

Any detail please either check the following link or contact me at any time.


So I setup a tftp server.

I transfered the files to flash/phones/7941_7961/

I then do tftp-server flash:phones/7941_7961/filename1.etc

(This is where I think the problem lies. I assume this is copying the files to the tftp server, but I get no confirmation)


load 7941 SCCP41.8-5-4S

load 7961 SCCP41.8-5-4S

then re create the cnf files. When rebooting the phones, they go to update, and I get error. Is there something I'm doing wrong?

Directory of flash:/phones/7941_7961/

    5  -rw-     2915997  Oct 30 2009 06:57:20 +13:00  apps41.8-4-1-23.sbn
    6  -rw-      459836  Oct 30 2009 06:57:24 +13:00  cnu41.8-4-1-23.sbn
    7  -rw-     2660448  Oct 30 2009 06:57:40 +13:00  cvm41sccp.8-4-1-23.sbn
    8  -rw-      539441  Oct 30 2009 06:57:44 +13:00  dsp41.8-4-1-23.sbn
    9  -rw-      500440  Oct 30 2009 06:57:48 +13:00  jar41sccp.8-4-1-23.sbn
   10  -rw-         638  Oct 30 2009 06:57:48 +13:00  SCCP41.8-4-2S.loads
   11  -rw-         654   Jan 9 2010 14:42:58 +12:00  term41.default.loads
   12  -rw-         654   Jan 9 2010 14:43:10 +12:00  term61.default.loads
  134  -rw-     2933341   Jan 9 2010 14:41:16 +12:00  apps41.8-5-4TH1-6.sbn
  135  -rw-      499863   Jan 9 2010 14:41:48 +12:00  cnu41.8-5-4TH1-6.sbn
  136  -rw-     2102770   Jan 9 2010 14:42:08 +12:00  cvm41sccp.8-5-4TH1-6.sbn
  137  -rw-      539513   Jan 9 2010 14:42:18 +12:00  dsp41.8-5-4TH1-6.sbn
  138  -rw-     1628021   Jan 9 2010 14:42:32 +12:00  jar41sccp.8-5-4TH1-6.sbn
  139  -rw-         650   Jan 9 2010 14:42:40 +12:00  SCCP41.8-5-4S.loads

9 Replies 9

Cisco Employee
Cisco Employee

As you had tac case open, assuming you got this issue resolved.....

let us know,


Ron Lewis


David Trad
VIP Alumni
VIP Alumni

Hi Hayden,

You need to make sure you have the following in your TFTP section, as you have displayed it now the firmware wont be read correctly.

See if this helps you out (Use the CLI to put it in ands remove the old stuff so you dont have a cluttered config).

tftp-server flash:/phones/7941_7961/apps41.8-3-4-16.sbn alias apps41.8-3-4-16.sbn
tftp-server flash:/phones/7941_7961/cnu41.8-3-4-16.sbn alias cnu41.8-3-4-16.sbn
tftp-server flash:/phones/7941_7961/cvm41sccp.8-3-4-16.sbn alias cvm41sccp.8-3-4-16.sbn
tftp-server flash:/phones/7941_7961/dsp41.8-3-4-16.sbn alias dsp41.8-3-4-16.sbn
tftp-server flash:/phones/7941_7961/jar41sccp.8-3-4-16.sbn alias jar41sccp.8-3-4-16.sbn
tftp-server flash:/phones/7941_7961/SCCP41.8-3-5S.loads alias SCCP41.8-3-5S.loads
tftp-server flash:/phones/7941_7961/term41.default.loads alias term41.default.loads
tftp-server flash:/phones/7941_7961/term61.default.loads alias term61.default.loads

OH i should mention the file names need to be replaced with the same file names on your flash card, make sure the file path and the alias names are updated to the ones you have on your flash card, your ones look the same as what i have listed for you, but please verify this for yourself.

Also i highly recommend you go and grab the latest ones from the Cisco site (Assuming SmartNet is still active on that device), i find normaly the latest firmware gets rid of some of the bugs and adds better support, there are newer ones in the Cisco Support download section.

I hope this helps you out.



Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

Thanks for the replies. I have tried what you have said, doesn't seem to work.

On the phones, it reboots to do the upgrade. Status says upgrading for about 15 seconds, then it says error and reboots.

I am currently doing it with one phone at a time. I am hoping to get a  webex session this morning.

Do you know how I can log this to see what the phone is trying to do?

Hello Hayden,

You can use CCA 2.x to upload phone software. Be sure to download the software pack - I just downloaded 8.0.0 - for the phone firmware you need. CCA has a built-in TFTP server, so be sure to disable 3rd party TFTP server on your PC.

1. From the CCA, click on Maintenance --> Phone Load Management.

2. Then click on the tab titled Upload Phone Loads.

3. In the Software Pack, click Browse to locate the software pack - in my case

4. Click Open on the software pack and CCA will read the phone loads located in the software pack.

5. Check the phone load you need

6. Click Upload

It may comes back and tell you all firmware has been loaded in flash. If that is the case, you will need to delete the old phone firmware first and then load the new version. The tab Delete Phone Loads will display all available phone firmware in flash. CCA will also checkmark phone loads that have not been used. Be sure to review the checked phone loads and uncheck the ones you want to keep. Otherwise, clicking on Delete will remove the checked phone loads.

For exmple, I needed to upgrade the SPA525 firmware from 7.1.7 to 7.4.2. First I deleted the old version using the Delete Phone Loads, then I loaded the new firmware from the 8.0.0 software pack using the steps above.

Once you have the phone firmware loaded, use CCA to reboot the phone. Highlight the phone, right-click--->Reboot.

The only thing left to do is clean up the tftp-server commands by deleting the entry. In my case:

UC520#conf t

UC520#no tftp-server flash:/phones/525/spa525g-7-1-9.bin alias spa525g-7-1-9.bin

I also verified the new version was also in the phone load command.

UC520#sh run | in load

load 525G spa525g-7-4-2

Hope this helps.

Bert Wilhelm

APW Solutions

Steven Smith
Level 7
Level 7

What is the error you are getting?  What is the current firmware version on the phones?  It might be useful to run a debug tftp events to see if there is a problem.  Also, you should run a debug tftp packets to make sure that you see the packets from the update.  I would do this with one phone at a time.

Level 1
Level 1

Thanks guys,

Got it sorted. Started fresh, loaded the files in the root of the flash and it seemed to work. All phones upgraded. I did think of using CCA. I actually think I tried this, but the phone loads were not there. I didn't know they had to be deleted for them to show.

Thanks for the tip.

Putting too many files in the root directory of flash can cause problems when you want to add more files to flash (limit of the file system).  That is why there is a directory structure.  I would recommend moving to a directory structure when you can.

I am pretty sure that CCA wants to see the flash directory structure as a support requirement....

Right. Now that the files are on the tftp server, moving the loads doesn't really matter (won't impact on firmware being updated) correct?

Thanks for the help.