cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
557
Views
0
Helpful
2
Replies

Translation rules not matching called number using sip trunk

lbroering
Beginner
Beginner

We

are setting up a sip trunk with a uc540 on version 8.1. Using cca 3.3. The outgoing call

s are working. The incoming calls receive a busy sig

nal or sometimes we will get a recording like "you have dialed an incorrect number"

The sip trunk provider is getting "an internal server error" returned to them from our uc540. Our debug log shows that the number does not find any matches in our translation rules.

The called number is +13304034026 and it seems like it should match this rule and send it to our auoattendant which is 398 -

voice translation-rule 4
rule 1 /^\+13304034026/ /398/

I am attaching a list of our translation rules and the output from the sip debug log generated by cca.What am I doing wrong?

1 Accepted Solution

Accepted Solutions

Nathan Compton
Enthusiast
Enthusiast

2 debugs you can run to see what is going on with this:

debug ccsip messages will show you what you are receiving from the carrier.

debug voip ccapi inout will show you how CME is processing the call.

8.1 added some SIP security settings that could possibly affect the inbound calling.  If it is, the debug voip ccapi inout will tell you if a call is blocked.

regards,

Adam Compton

View solution in original post

2 Replies 2

Nathan Compton
Enthusiast
Enthusiast

2 debugs you can run to see what is going on with this:

debug ccsip messages will show you what you are receiving from the carrier.

debug voip ccapi inout will show you how CME is processing the call.

8.1 added some SIP security settings that could possibly affect the inbound calling.  If it is, the debug voip ccapi inout will tell you if a call is blocked.

regards,

Adam Compton

Nathan

Your commands really helped. We were able to see that some ip addresses were being blocked during a call session. We added 3 ip addresses to the SIP Access Group access-list and that fixed the problem. Bandwidth says that we should never see those servers, but the calls did not go through till we added them to the allow list. As side note, we could have added those to the additional servers tab in the Generic SIP trunk set up, but we did not realize it until we added those in cli. Thanks again.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: