Showing results for 
Search instead for 
Did you mean: 

Anyconnect- big sur connection issue after sleep

Level 1
Level 1

running anyconnect 4.9.0404 with Big Sur. Sometimes when the mac going to sleep and wakes up again, the connection cannot be established. Restart the mac will solve it - or a re-install will also do it. So something needs to be hanging after sleep, but I don´t know what I should look for since the connection cannot be established.


Anyone know about how to solve this ?

6 Replies 6

Dinesh Moudgil
Cisco Employee
Cisco Employee

Hi ,


There is a bug on AC 4.9 related to Big Sur.


Could you please perhaps try using latest AC version 4.9.06037 and confirm if the symptoms are the same ?




Cisco Network Security Channel -

Hi out there

The problem is certainly not solved - we are seeing exactlyt the same symptoms - we have a base of 100 mac we cannot update to big sur since our "beta-testers" on big sur are suffering under this problem - and that has been on-going now for 1/2 year

we are up on the latest AnyConnect 4.10.02086 as the latest suggestion from Ciscos supporters - but still the same problem

Level 1
Level 1

For me, this issue is intermittent but happens a lot and happened on both Catalina and Big Sur. Sometimes it will affect both Ethernet and WIFI or sometime only the WIFI. My colleague and I figured is that if we kill vpnagentd and restart the affected network interfaces, that it will help bring them back without having to restart the Mac. If it helps anyone, here's the bash script that I crafted that serves as a workaround for this so you won't have to reboot:


function restartNetworkInterfaces()
  for net_interface in ${net_interfaces[@]}; do
    echo "Restarting interface: ${net_interface}"
    sudo ifconfig ${net_interface} down
    sudo ifconfig ${net_interface} up
    ifconfig -u ${net_interface}


VPNAGENTD="/opt/cisco/anyconnect/bin/vpnagentd -execv_instance"
echo "Restarting ${VPNAGENTD}"
sudo pkill -9 -f ${VPNAGENTD}

ETHERNET_INT=`networksetup -listnetworkserviceorder | sed -En 's|^\(Hardware Port: .*Ethernet.*, Device: (en.)\)$|\1|p'`
restartNetworkInterfaces "${ETHERNET_INT[@]}"
WIFI_INT=`networksetup -listnetworkserviceorder | sed -En 's/^\(Hardware Port: (Wi-Fi|AirPort), Device: (en.)\)$/\2/p'`
restartNetworkInterfaces "${WIFI_INT[@]}"

Another scenario which I felt is related to this is that my MAC will just auto reboot because of a panic from waking up. Did anyone experience this too?

Level 3
Level 3

hi again

It looks as if the latest MacOS (11.6.something) and AC 4.10.02086 has solved the problems - been stable since we got these updates

Level 1
Level 1

I'm on that version, i.e. 4.10.02086 and I'm still getting the issue.

Level 3
Level 3

well - the problem is probably not as much AnyConnect but MacOS - if you are on 11.6.1 then would I guess that the symptoms disappear...