05-14-2017 06:09 PM - edited 02-21-2020 09:17 PM
I can connect via the Anyconnect client but I can't access any internal network resources or ping. Can anyone help?
hostname TheWriter
enable password fhmrSO.ojbChfBGi encrypted
xlate per-session deny tcp any4 any4
xlate per-session deny tcp any4 any6
xlate per-session deny tcp any6 any4
xlate per-session deny tcp any6 any6
xlate per-session deny udp any4 any4 eq domain
xlate per-session deny udp any4 any6 eq domain
xlate per-session deny udp any6 any4 eq domain
xlate per-session deny udp any6 any6 eq domain
passwd 2KFQnbNIdI.2KYOU encrypted
names
ip local pool ANYCONNECT-POOL 192.168.20.50-192.168.20.254 mask 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 3
!
interface Ethernet0/1
switchport access vlan 17
!
interface Ethernet0/2
switchport access vlan 17
!
interface Ethernet0/3
switchport access vlan 17
!
interface Ethernet0/4
switchport access vlan 17
shutdown
!
interface Ethernet0/5
switchport access vlan 17
shutdown
!
interface Ethernet0/6
switchport access vlan 17
shutdown
!
interface Ethernet0/7
switchport access vlan 17
shutdown
!
interface Vlan1
no nameif
no security-level
no ip address
!
interface Vlan3
nameif outside
security-level 0
ip address dhcp setroute
!
interface Vlan17
nameif inside
security-level 100
ip address 192.168.17.1 255.255.255.0
!
boot system disk0:/asa913-k8.bin
ftp mode passive
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network OBJ-ANYCONNECT-SUBNET
subnet 192.168.100.0 255.255.255.0
access-list SPLIT-TUNNEL standard permit 192.168.17.0 255.255.255.0
access-list SERVER extended permit tcp any host 192.168.17.20 eq 3389
pager lines 24
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-714.bin
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static any any destination static OBJ-ANYCONNECT-SUBNET OBJ-ANYCONNECT-SUBNET no-proxy-arp route-lookup
!
object network obj_any
nat (inside,outside) dynamic interface
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.17.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
ssh 192.168.17.0 255.255.255.0 inside
ssh timeout 30
ssh version 2
ssh key-exchange group dh-group1-sha1
console timeout 0
dhcp-client client-id interface outside
dhcpd address 192.168.17.50-192.168.17.200 inside
dhcpd dns 75.75.75.75 75.75.76.76 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
enable outside
anyconnect image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
anyconnect enable
tunnel-group-list enable
group-policy GroupPolicy_ANYCONNECT-PROFILE internal
group-policy GroupPolicy_ANYCONNECT-PROFILE attributes
dns-server value 75.75.75.75 75.75.76.76
vpn-tunnel-protocol ssl-client
split-tunnel-policy tunnelspecified
split-tunnel-network-list value SPLIT-TUNNEL
default-domain value drs.com
username cwkronk password ORCwAqMqhy9Dai/1 encrypted
username admin password tTjX9Q.OOrby.02Z encrypted
username netadmin password ecyGuRt3I21zrGTM encrypted privilege 15
tunnel-group ANYCONNECT-PROFILE type remote-access
tunnel-group ANYCONNECT-PROFILE general-attributes
address-pool ANYCONNECT-POOL
default-group-policy GroupPolicy_ANYCONNECT-PROFILE
tunnel-group ANYCONNECT-PROFILE webvpn-attributes
group-alias ANYCONNECT-PROFILE enable
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:c205a22295407eeb7f8f5f9092ed3af2
: end
05-14-2017 09:03 PM
Is everything you are trying to reach reside in the 192.168.17.0/24 subnet? If so, the ASA configuration looks pretty clean.
Can you confirm that the hosts in the subnet have the ASA as their defaiult gateway?
05-15-2017 03:07 AM
The inside address is 192.168.17.15. Everything works otherwise.
When my PC is connected to the ASA via the Anyconnect client the one network card addresses were:
192.168.20.50/24. There was no default gateway assigned.
The second address was 192.168.43.201/24 gateway: 192.168.43.1
First, should the 192.168.20.0/24 network have a gateway? That's the pool for the VPN clients. If so, should it be 192.168.20.1 or 192.168.17.1 (with 17.1 being the inside LAN)?
Second, where is the 192.168.43.0/24 network coming from? I don't remember adding it to the config and don't see it in the config.
My computer accesses the internet without issue when connected to the VPN client.
05-15-2017 03:25 AM
object network OBJ-ANYCONNECT-SUBNET
subnet 192.168.100.0 255.255.255.0
^^That's wrong. The VPN pool is 192.168.20.0/24. I accidentally used the one in the config provided I found online. /face palm
It works now though, :D
05-15-2017 04:42 AM
ooops - that will certainly do it. Thanks for letting us know the resolution.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide