cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
408
Views
5
Helpful
3
Replies
Highlighted
Beginner

Anyconnect VPN to site to site intermittent / NAT audit needed.

Hi everyone. I'll post the config at the end - please allow for my brief commentary.

 

I have a working site to site between two asa. I also have a working anyconnect ssl session to the main site. I am not interested in split tunneling, tunnel all is necessary for the anyconnect users. When I have no nat rule in place, anyconnect users cannot access the internet but CAN access the local and remote sites as desired. When I apply a nat rule to allow for internet access, the anyconnect users no longer have access to the remote site. NAT is my weak point, so I am kindly requesting a nat audit and suggestions to make this work. Thank you greatly for your attention.

 

Config: ***when can access remote site but no internet***

 

asax# sh ru
: Saved

:
: Serial Number: redacted
: Hardware: ASA5525, 8192 MB RAM, CPU Lynnfield 2400 MHz, 1 CPU (4 cores)
:
ASA Version 9.13(1)
!
hostname redacted
domain-name redacted
enable password redacted
names
no mac-address auto

!
interface GigabitEthernet0/0
nameif VPN_IN
security-level 0
ip address 192.168.100.2 255.255.255.252
!
interface GigabitEthernet0/1
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/4
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet0/6
nameif VPN_LOCAL
security-level 0
ip address 10.211.0.2 255.255.255.128
!
interface GigabitEthernet0/7
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
management-only
shutdown
no nameif
no security-level
no ip address
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup VPN_LOCAL
dns server-group DefaultDNS
name-server 10.11.12.11 VPN_LOCAL
name-server 10.11.12.12 VPN_LOCAL
domain-name redacted
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network NETWORK_OBJ_10.11.12.20_30
subnet 10.11.12.20 255.255.255.252
object network vpn-subnet
subnet 10.211.0.0 255.255.255.128
object-group network DM_INLINE_NETWORK_1
network-object 10.11.12.0 255.255.255.128
network-object 10.211.0.0 255.255.255.128
network-object 10.95.5.0 255.255.255.0
object-group network DM_INLINE_NETWORK_2
network-object 10.100.0.0 255.255.255.240
network-object 172.30.15.0 255.255.255.248
access-list VPN_IN_cryptomap extended permit ip object-group DM_INLINE_NETWORK_1 object-group DM_INLINE_NETWORK_2
pager lines 24
mtu VPN_IN 1500
mtu VPN_LOCAL 1500
no failover
no monitor-interface service-module
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
arp rate-limit 16384
nat (VPN_LOCAL,VPN_IN) source static DM_INLINE_NETWORK_1 DM_INLINE_NETWORK_1 destination static DM_INLINE_NETWORK_2 DM_INLINE_NETWORK_2 no-proxy-arp route-lookup
route VPN_IN 0.0.0.0 0.0.0.0 192.168.100.1 1
route VPN_LOCAL 10.11.12.0 255.255.255.128 10.211.0.1 1
route VPN_LOCAL 10.95.5.0 255.255.255.0 10.211.0.1 1
route VPN_LOCAL 172.16.16.0 255.255.255.224 10.211.0.1 1
route VPN_LOCAL 172.30.10.0 255.255.255.240 10.211.0.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 sctp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
timeout conn-holddown 0:00:15
timeout igp stale-route 0:01:10
user-identity default-domain LOCAL
aaa authentication login-history
http server enable
http 0.0.0.0 0.0.0.0 VPN_LOCAL
no snmp-server location
no snmp-server contact
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
crypto ipsec ikev2 ipsec-proposal AES256
protocol esp encryption aes-256
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES192
protocol esp encryption aes-192
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal AES
protocol esp encryption aes
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal 3DES
protocol esp encryption 3des
protocol esp integrity sha-1 md5
crypto ipsec ikev2 ipsec-proposal DES
protocol esp encryption des
protocol esp integrity sha-1 md5
crypto ipsec security-association pmtu-aging infinite
crypto map VPN_IN_map 1 match address VPN_IN_cryptomap
crypto map VPN_IN_map 1 set peer pe.er.ip.123
crypto map VPN_IN_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map VPN_IN_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
crypto map VPN_IN_map interface VPN_IN
crypto ca trustpoint wildcard
keypair ASDM_TrustPoint0
crl configure
crypto ca trustpool policy
crypto ca certificate chain wildcard
redacted
quit
crypto ikev2 policy 1
encryption aes-256
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 10
encryption aes-192
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 20
encryption aes
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 30
encryption 3des
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 policy 40
encryption des
integrity sha
group 5 2
prf sha
lifetime seconds 86400
crypto ikev2 enable VPN_IN
crypto ikev1 policy 10
authentication pre-share
encryption aes-256
hash sha
group 14
lifetime 86400
crypto ikev1 policy 20
authentication rsa-sig
encryption aes-256
hash sha
group 14
lifetime 86400
crypto ikev1 policy 40
authentication pre-share
encryption aes-192
hash sha
group 14
lifetime 86400
crypto ikev1 policy 50
authentication rsa-sig
encryption aes-192
hash sha
group 14
lifetime 86400
crypto ikev1 policy 70
authentication pre-share
encryption aes
hash sha
group 14
lifetime 86400
crypto ikev1 policy 80
authentication rsa-sig
encryption aes
hash sha
group 14
lifetime 86400
crypto ikev1 policy 100
authentication pre-share
encryption 3des
hash sha
group 14
lifetime 86400
crypto ikev1 policy 110
authentication rsa-sig
encryption 3des
hash sha
group 14
lifetime 86400
crypto ikev1 policy 130
authentication pre-share
encryption des
hash sha
group 14
lifetime 86400
crypto ikev1 policy 140
authentication rsa-sig
encryption des
hash sha
group 14
lifetime 86400
telnet timeout 5
ssh stricthostkeycheck
ssh timeout 5
ssh version 2
ssh key-exchange group dh-group14-sha256
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 10.211.0.1 source VPN_LOCAL prefer
ssl trust-point wildcard VPN_IN
ssl trust-point wildcard VPN_LOCAL
webvpn
port redacted
enable VPN_IN
dtls port redacted
http-headers
hsts-server
enable
max-age 31536000
include-sub-domains
no preload
hsts-client
enable
x-content-type-options
x-xss-protection
content-security-policy
anyconnect image disk0:/anyconnect-win-4.8.03052-webdeploy-k9.pkg 1
anyconnect enable
tunnel-group-list enable
cache
disable
error-recovery disable
group-policy DfltGrpPolicy attributes
vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-clientless
group-policy "GroupPolicy_DS VPN" internal
group-policy "GroupPolicy_DS VPN" attributes
wins-server none
dns-server value 10.11.12.11 10.11.12.12
dhcp-network-scope 10.211.0.0
vpn-tunnel-protocol ssl-client
default-domain value redacted
group-policy GroupPolicy_pe.er.ip.123 internal
group-policy GroupPolicy_pe.er.ip.123 attributes
vpn-tunnel-protocol ikev2
dynamic-access-policy-record DfltAccessPolicy
username redacted
tunnel-group pe.er.ip.123 type ipsec-l2l
tunnel-group pe.er.ip.123 general-attributes
default-group-policy GroupPolicy_pe.er.ip.123
tunnel-group pe.er.ip.123 ipsec-attributes
ikev1 pre-shared-key *****
ikev2 remote-authentication pre-shared-key *****
ikev2 local-authentication pre-shared-key *****
tunnel-group "DS VPN" type remote-access
tunnel-group "DS VPN" general-attributes
default-group-policy "GroupPolicy_DS VPN"
dhcp-server subnet-selection 10.11.12.16
tunnel-group "DS VPN" webvpn-attributes
group-alias "DS VPN" enable
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map global_policy
class inspection_default
inspect ftp
inspect h323 h225
inspect h323 ras
inspect ip-options
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
inspect dns preset_dns_map
policy-map type inspect dns migrated_dns_map_2
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
policy-map type inspect dns migrated_dns_map_1
parameters
message-length maximum client auto
message-length maximum 512
no tcp-inspection
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Advisor

Hi,

You need to ensure that you have NAT Exemption rules in place to ensure traffic to/from AnyConnect to the LAN or the Remote Sites is not natted. Here is an example of what you need (replace the objects in the example below, obviously):-

 

nat (VPN_LOCAL,VPN_IN) source static LOCAL_LAN_NET LOCAL_LAN_NET destination static RAVPN_NET RAVPN_NET
nat (VPN_IN,VPN_IN) source static RAVPN_NET RAVPN_NET destination static DM_INLINE_NETWORK_2 DM_INLINE_NETWORK_2

 

The rules above will apply first, you can then NAT the RAVPN traffic destined to the internet. Example:-

 

object network RAVPN_NET
 nat (VPN_IN,VPN_IN) dynamic interface

 

HTH

View solution in original post

3 REPLIES 3
Highlighted
VIP Advisor

Hi,

You need to ensure that you have NAT Exemption rules in place to ensure traffic to/from AnyConnect to the LAN or the Remote Sites is not natted. Here is an example of what you need (replace the objects in the example below, obviously):-

 

nat (VPN_LOCAL,VPN_IN) source static LOCAL_LAN_NET LOCAL_LAN_NET destination static RAVPN_NET RAVPN_NET
nat (VPN_IN,VPN_IN) source static RAVPN_NET RAVPN_NET destination static DM_INLINE_NETWORK_2 DM_INLINE_NETWORK_2

 

The rules above will apply first, you can then NAT the RAVPN traffic destined to the internet. Example:-

 

object network RAVPN_NET
 nat (VPN_IN,VPN_IN) dynamic interface

 

HTH

View solution in original post

Highlighted

Ok, thats not at all the right syntax I thought would be the correct way to do it, but it completely works.

 

In the first nat statement for LOCAL_LAN_NET, would any local subnet the RAVPN wants access need to go here (its multiple) separate from any static routes I create?

Highlighted

Correct, add all your internal networks (local to the ASA) to the object LOCAL_LAN_NET that the Remote Access VPN user would need access to. Yes, this NAT is independant from the static routes.

HTH