Hi everyone,
I've been digging around the forum and haven't found a solution to my issue.
I configured an old 1711 router for a home office setup while waiting for Skydrive. They have a fairly old cable modem only capable of forwarding tcp/1723 for PPTP (not GRE) which is being sent to the router.
I've had some gradual success in getting this to work, and at the moment the error I'm receiving is (debug ppp auth, error, neg)
*Mar 20 22:50:48.209: ppp15 PPP: Using vpn set call direction
*Mar 20 22:50:48.209: ppp15 PPP: Treating connection as a callin
*Mar 20 22:50:48.209: ppp15 PPP: Phase is ESTABLISHING, Passive Open
*Mar 20 22:50:48.209: ppp15 LCP: State is Listen
*Mar 20 22:50:50.213: ppp15 LCP: TIMEout: State Listen
*Mar 20 22:50:50.213: ppp15 PPP: Authorization NOT required
*Mar 20 22:50:50.213: ppp15 LCP: O CONFREQ [Listen] id 1 len 15
*Mar 20 22:50:50.213: ppp15 LCP: AuthProto MS-CHAP (0x0305C22380)
*Mar 20 22:50:50.213: ppp15 LCP: MagicNumber 0x3B4AE7CD (0x05063B4AE7CD)
*Mar 20 22:50:52.229: ppp15 LCP: TIMEout: State REQsent
*Mar 20 22:51:10.373: ppp15 LCP: O TERMREQ [REQsent] id 10 len 4
*Mar 20 22:51:10.373: ppp15 PPP: Phase is TERMINATING
*Mar 20 22:51:10.373: ppp15 LCP: State is Listen
*Mar 20 22:51:10.373: ppp15 PPP: Sending Acct Event[Down] id[1CC6]
*Mar 20 22:51:10.373: ppp15 LCP: State is Closed
*Mar 20 22:51:10.373: ppp15 PPP: Phase is DOWN
Here is my config
Current configuration : 1801 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname jims-router
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxx
!
username admin password 7 xxxxx
username jim.bob password 7 xxxxx
username karl privilege 15 secret 5 xxxxx
memory-size iomem 15
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
aaa new-model
!
!
aaa authentication login VTY local
aaa authentication ppp default local
aaa session-id common
ip subnet-zero
!
!
ip domain name jims.local
!
!
ip cef
ip audit po max-events 100
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
protocol pptp
virtual-template 1
!
no ftp-server write-enable
!
!
!
!
!
no crypto isakmp enable
!
!
!
interface Loopback0
ip address 192.168.237.65 255.255.255.192
!
interface FastEthernet0
ip address dhcp
duplex auto
speed auto
!
interface FastEthernet1
no ip address
shutdown
!
interface FastEthernet2
no ip address
shutdown
!
interface FastEthernet3
no ip address
shutdown
!
interface FastEthernet4
no ip address
shutdown
!
interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address pool jims
no keepalive
ppp encrypt mppe 128
ppp authentication ms-chap ms-chap-v2
!
interface Vlan1
no ip address
!
interface Async1
no ip address
!
ip local pool jims 192.168.237.70 192.168.237.75
ip classless
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
line 1
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
login authentication VTY
transport input ssh
line vty 5 15
!
!
end
Thanks in advanced,
KJ