02-18-2010 06:32 AM
Hello!
I've 2 ASA 5505 connected with VPN Tunnel IPSEC Site-to-Site.
One "remote" 192.168.1.0/24 inside network and one local "192.168.200.0/24" inside network (you can see the schema)
The local host have 192.168.200.254 as default gateway.
I can't add static route to all host and I can't add static route to 192.168.200.254.
Can I NAT the incoming VPN as 192.168.200.1 or one 192.168.200.x free for connect correcly my host?
Otherwise my host send output packet to default gateway.
Thanks for your support
Best Regards
Marco
Solved! Go to Solution.
02-18-2010 11:38 AM
The configuration has to be applied on the ASA with the 192.168.200.0 subnet on it's inside, it has to be something like this:
access-list VPN_NAT permit ip 192.168.1.0 255.255.255.0 192.168.200.0 255.255.255.0
nat (outside) X access-list VPN_NAT outside
global (inside) X Y.Y.Y.Y (where the Y.Y.Y.Y) is the ip address
If you have other traffic on the vpn going through the tunnel that does not require nat, then you need to add outside nat exemption rules since these lines above forces all traffic through the asa to have a nat statement.
See if this works for you, else post your nat config here.
02-18-2010 08:58 AM
Hi Marco,
You can certainly do Destination nat to Nat your 192.168.1.0 to something on the 192.168.200.0/24 but here is the catch, first you need to make sure that what you are going to use as the address to nat to is not used, then if you want to use a one to one nat for each of the 192.168.1.0 there should be an available address on the 192.168.200.0 which in will cause you overlaps and problems. If you however have a set of defined servers you need to reach on the 192.168.1.0 then you can use one to one nat to those servers with the 192.168.200.X..
This if course if you need bidirectional communication.
02-18-2010 11:08 AM
Hi Ivan,
thanks for you reply!
Can I NAT all 192.168.1.0/24 with only one "free" 192.168.200.x?
Trying to do some test I receive this error: Asymmetric NAT rules matched for forward and reverse flows
Thanks again!
Marco
02-18-2010 11:11 AM
You can use this kind of natting but it will be called PAT, and it will not be bidirectional, meaning only traffic replying to a previos request from the 192.168.1.0/24 network will be able to pass back, but if you start a connection from the 192.168.200.0/24 network to this available .200 host connection will never go through.
02-18-2010 11:28 AM
Thanks again Ivan!
Yes, PAT is the correct way for me!
The direction is always 192.168.1.0/24 to host 192.168.200.0/24
Unfortunately I'm not able to do this PAT.
With my test I always receive the "Asymmetric NAT" error during packet transit from ASA1 to ASA2
Have you a simple cfg for this?
Best regards
Marco
02-18-2010 11:38 AM
The configuration has to be applied on the ASA with the 192.168.200.0 subnet on it's inside, it has to be something like this:
access-list VPN_NAT permit ip 192.168.1.0 255.255.255.0 192.168.200.0 255.255.255.0
nat (outside) X access-list VPN_NAT outside
global (inside) X Y.Y.Y.Y (where the Y.Y.Y.Y) is the ip address
If you have other traffic on the vpn going through the tunnel that does not require nat, then you need to add outside nat exemption rules since these lines above forces all traffic through the asa to have a nat statement.
See if this works for you, else post your nat config here.
02-19-2010 01:51 AM
Dear Ivan,
you have solved me my problem! Very very thanks!
I've an old similar problem.
I need to PAT traffic from 192.168.1.0/24 (through VPN) to remote 151.1.1.0/24, through router 192.168.123.9 in dmz (see schema)
With your same configuration it works, except for ICMP.
This is the error: Deny inbound icmp src dmz:151.1.1.1 dst outside:192.168.123.229 (type 0, code 0)
Is there a way for this?
Thanks again!
Marco
------------------------------------------------------------------------------------
ASA Version 8.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.1.0 remote-network
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.200.199 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 10.0.0.2 255.255.255.0
!
interface Vlan3
no forward interface Vlan1
nameif dmz
security-level 0
ip address 192.168.123.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
switchport access vlan 3
!
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
object-group network DM_INLINE_NETWORK_1
network-object 151.1.1.0 255.255.255.0
network-object 192.168.200.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip object-group DM_INLINE_NETWORK_1 remote-network 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.200.0 255.255.255.0 remote-network 255.255.255.0
access-list VPN_NAT extended permit ip remote-network 255.255.255.0 151.1.1.0 255.255.255.0
access-list dmz_access_in extended permit icmp any any
access-list outside_access_in extended permit icmp any any
pager lines 24
logging enable
logging asdm notifications
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any dmz
asdm image disk0:/asdm-625.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
global (dmz) 5 192.168.123.229
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.200.0 255.255.255.0
nat (outside) 5 access-list VPN_NAT outside
access-group outside_access_in in interface outside
access-group dmz_access_in in interface dmz
route outside 0.0.0.0 0.0.0.0 10.0.0.100 1
route dmz 151.1.1.0 255.255.255.0 192.168.123.9 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 0.0.0.0 0.0.0.0 inside
http remote-network 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer 10.0.0.1
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
tunnel-group 10.0.0.1 type ipsec-l2l
tunnel-group 10.0.0.1 ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
call-home
profile CiscoTAC-1
no active
destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
destination address email callhome@cisco.com
destination transport-method http
subscribe-to-alert-group diagnostic
subscribe-to-alert-group environment
subscribe-to-alert-group inventory periodic monthly
subscribe-to-alert-group configuration periodic monthly
subscribe-to-alert-group telemetry periodic daily
------------------------------------------------------------------------------------
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide