04-26-2013 05:26 AM
I'm trying to setup remote access vpn to the ASA 5505 in my office.
The config is setup on my ASA, and I have cisco vpn client 5.0.07 installed on my Windows 7 (64-bit) laptop. I can start the vpn, put in my credentials, and it looks like everything goes through, but once I'm connected, I lose access to the internet, and I can't ping anything (4.2.2.2, 192.168.1.1 (default gateway), etc...)
I keep seeing something about uncheck "use default gateway on remote network", but this option isn't available in TCP/IP properties. Any suggestions?
Solved! Go to Solution.
04-29-2013 10:37 AM
Eric,
This should be the last change. Looks like you do not have inside network in split tunnel.
Here is the entry you need to make
access-list TunnelSplit1 standard permit 192.168.1.0 255.255.255.0
disconnect and connect again. It should work like a charm.
Thanks,
Varinder
04-26-2013 08:58 AM
Hi Eric,
Please post your config on the forum, so that it is easy to advise what need to be corrected, please do not forget to remove login-credential/password from it.
thanks
04-26-2013 09:09 AM
Config is below. A few things to note,
-When the remote client VPNs into the office, I'm able to remote desktop to the vpn client, so I know that 's it's getting across the tunnel
-The network at the remote site and in the office are the same (192.168.1.0), so I'm not sure if that will cause an issue, and If I should change the network in the office
hostname WayneASA
enable password xxxxxx encrypted
passwd xxxxxxxxx encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 70.91.18.205 255.255.255.252
!
interface Vlan5
shutdown
no nameif
security-level 50
ip address 192.168.10.1 255.255.255.0
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server 75.75.75.75
name-server 75.75.76.76
domain-name 3gtms.com
access-list inside_access_in extended permit ip any any
access-list cap extended permit ip host 192.168.1.112 host 70.91.18.205
access-list cap extended permit ip host 70.91.18.205 host 192.168.1.112
access-list cap extended permit ip host 70.91.18.205 host 70.91.18.206
access-list cap extended permit ip host 70.91.18.206 host 70.91.18.205
pager lines 24
logging enable
logging buffered debugging
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNPool 192.168.1.200-192.168.1.225
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 70.91.18.206 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set VPNTransformSet esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map DynamicMap 1 set pfs group1
crypto dynamic-map DynamicMap 1 set transform-set VPNTransformSet
crypto dynamic-map VPNDynamicMap 1 set reverse-route
crypto map VPNMap 1 ipsec-isakmp dynamic DynamicMap
crypto map VPNMap interface outside
crypto ca trustpoint _SmartCallHome_ServerCA
crl configure
crypto ca certificate chain _SmartCallHome_ServerCA
certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
6c2527b9 deb78458 c61f381e a4c4cb66
quit
crypto isakmp enable outside
crypto isakmp policy 1
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 43200
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 20
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.100-192.168.1.199 inside
dhcpd dns 75.75.75.75 75.75.76.76 interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
group-policy VPNTunnelGroup2 internal
group-policy VPNTunnelGroup2 attributes
dns-server value 75.75.75.75 75.75.76.76
vpn-tunnel-protocol IPSec
default-domain value 3gtms.com
username eric password 0vcSd5J/TLsFy7nU encrypted privilege 15
tunnel-group VPNTunnelGroup type remote-access
tunnel-group VPNTunnelGroup general-attributes
address-pool VPNPool
tunnel-group VPNTunnelGroup ipsec-attributes
pre-shared-key *****
tunnel-group VPNTunnelGroup2 type remote-access
tunnel-group VPNTunnelGroup2 general-attributes
address-pool VPNPool
default-group-policy VPNTunnelGroup2
tunnel-group VPNTunnelGroup2 ipsec-attributes
pre-shared-key *****
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map global_policy
class inspection_default
inspect icmp
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
inspect dns
!
service-policy global_policy global
prompt hostname context
call-home reporting anonymous
Cryptochecksum:171c6247d96635a868ad37df4460ed9e
: end
04-26-2013 09:44 AM
Hi Matelyan,
Here is what you need to do.
Step 1: Create an acl as shown below: inside_nat0
access-list inside_nat0 extended permit ip 192.168.1.0 255.255.255.0 192.168.1.92 255.255.255.224
Step 2: Create an acl as shown below: TunnelSplit1
access-list TunnelSplit1 standard permit 192.168.1.92 255.255.255.224
Step 3: Apply the acl: inside_nat0 as shown below.
nat (inside) 0 access-list inside_nat0
Step 4: Apply the acl in the tunnel group: VPNTunnelGroup, I assume this is your active tunnel group you are using to login with on remote access.
tunnel-group VPNTunnelGroup general-attributes
split-tunnel-network-list value TunnelSplit1
FYI...
It is not recommanded to pull out an IP range from thin air as "192.168.1.200-192.168.1.225" but rather keep complete a
separate subnet for vpn-client users and around it off to a particular subnet, as you can see, the above vpn-client pool range cannot be arounded off to any subnet range because it overlaps.
If you have an internal switch please be sure to add a static route on the switch to firewall as shown below, as this segment (i.e. 192.168.1.92 255.255.255.224) is coming off the firwall itself
ip route 192.168.1.92 255.255.255.224 192.168.1.1
Thanks
Rizwan Rafeek
04-26-2013 11:41 AM
ok, so you are saying to make the VPNPool 192.168.1.92 - 192.168.1.123?
I guess I should change the DHCP pool to function the same? I currently am using 100-199, but should I change it to something like 124-242?
And as for the ip route, I would put that on the switch, or on the firewall? The switch currently is not doing any routing, so would that be necessary?
04-26-2013 12:07 PM
Hi Eric,
"ok, so you are saying to make the VPNPool 192.168.1.92 - 192.168.1.123?"
Lets use a completely separate subnet altogether from below table, a subnet separate from inside interface.
Subnet | Network Address | Starting Host | End Host | Broadcast | Netmask |
0 | 192.168.2.0 | 192.168.2.1 | 192.168.2.30 | 192.168.2.31 | 255.255.255.224 |
1 | 192.168.2.32 | 192.168.2.33 | 192.168.2.62 | 192.168.2.63 | 255.255.255.224 |
2 | 192.168.2.64 | 192.168.2.65 | 192.168.2.94 | 192.168.2.95 | 255.255.255.224 |
3 | 192.168.2.96 | 192.168.2.97 | 192.168.2.126 | 192.168.2.127 | 255.255.255.224 |
4 | 192.168.2.128 | 192.168.2.129 | 192.168.2.158 | 192.168.2.159 | 255.255.255.224 |
5 | 192.168.2.160 | 192.168.2.161 | 192.168.2.190 | 192.168.2.191 | 255.255.255.224 |
6 | 192.168.2.192 | 192.168.2.193 | 192.168.2.222 | 192.168.2.223 | 255.255.255.224 |
7 | 192.168.2.224 | 192.168.2.225 | 192.168.2.254 | 192.168.2.255 | 255.255.255.224 |
Subnet | Network Address | Starting Host | End Host | Broadcast | Netmask |
0 | 192.168.2.0 | 192.168.2.1 | 192.168.2.30 | 192.168.2.31 | 255.255.255.224 |
1 | 192.168.2.32 | 192.168.2.33 | 192.168.2.62 | 192.168.2.63 | 255.255.255.224 |
2 | 192.168.2.64 | 192.168.2.65 | 192.168.2.94 | 192.168.2.95 | 255.255.255.224 |
3 | 192.168.2.96 | 192.168.2.97 | 192.168.2.126 | 192.168.2.127 | 255.255.255.224 |
4 | 192.168.2.128 | 192.168.2.129 | 192.168.2.158 | 192.168.2.159 | 255.255.255.224 |
5 | 192.168.2.160 | 192.168.2.161 | 192.168.2.190 | 192.168.2.191 | 255.255.255.224 |
6 | 192.168.2.192 | 192.168.2.193 | 192.168.2.222 | 192.168.2.223 | 255.255.255.224 |
7 | 192.168.2.224 | 192.168.2.225 | 192.168.2.254 | 192.168.2.255 | 255.255.255.224 |
Lets take subnet zero from table above for vpn-pool.
Now use that particular range in the acl inside_nat0 and TunnelSplit1 as show below.
access-list inside_nat0 extended permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.224
access-list TunnelSplit1 standard permit 192.168.2.0 255.255.255.224
Now apply both ACLs accordingly as mentioned above.
"And as for the ip route, I would put that on the switch, or on the firewall? The switch currently is not doing any routing, so would that be necessary?"
As long as your inside PCs or servers has Firewall as their gateway address (i.e.firewall inside address), it is should work, even without a default-route or static-route on the inside switch.
Thanks
Rizwan Rafeek
04-26-2013 11:34 AM
Matelyan,
Since you are using tunnel all configuation for vpn. You would need to configure U turning for VPN traffic. Below are the commands you would require to configure:
same-security-traffic permit intra-interface
nat (outside) 1 192.168.1.192 255.255.255.192
This will allow traffic to be natted on outside interface.
Alternatively you can configure split tunnel as suggested by Rizwan.
Hope that helps.
Varinder
04-26-2013 11:52 AM
Ideally you should have vpn pool network different from internal network. This will negate issue with routing as well as help you filter traffic.
So here are the commands you would require
ip local pool VPNPool 192.168.2.1-192.168.2.225
access-list nonat permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
nat (inside) 0 access-list nonat
nat (outside) 1 192.168.2.0 255.255.255.0
same-security-traffic permit intra-interface
This should take care of routing issue as well.
Varinder
04-26-2013 12:53 PM
Hello Rizwan,
ok, I'm at the last step and having an issue.
I go here from Config mode ->>> tunnel-group VPNTunnelGroup general-attributes
This command is not available --->>> split-tunnel-network-list value TunnelSplit1
04-26-2013 01:05 PM
Hi Eric,
Apply this first the highlighted command below and second the other.
VPNTunnelGroup general-attributes
split-tunnel-policy tunnelspecified
split-tunnel-network-list value TunnelSplit1
Thanks
Rizwan Rafeek
04-26-2013 01:09 PM
Hi Eric,
"I go here from Config mode ->>> tunnel-group VPNTunnelGroup general-attributes"
It does not go on tunnel-group but rather on "group-policy"
group-policy VPNTunnelGroup2 attributes
split-tunnel-policy tunnelspecified
split-tunnel-network-list value TunnelSplit1
sorry about that.
thanks
04-26-2013 01:18 PM
From your last post, still no luck.
Also, I deleted VPNTunnelGroup2, as it's the same as VPNTunnelGroup. I created two groups as I was figuring it out.
04-26-2013 01:30 PM
Hi Eric,
First you issue this command first: "group-policy VPNTunnelGroup attributes"
Other two commands are sub-commands from above command.
split-tunnel-policy tunnelspecified
split-tunnel-network-list value TunnelSplit1
thanks
Rizwan Rafeek
04-26-2013 01:42 PM
See below, when I enter this command, it doesn't recognize the "attributes" command
04-26-2013 02:00 PM
Hi Eric,
Try this please.
group-policy VPNTunnelGroup internal
group-policy VPNTunnelGroup attributes
split-tunnel-policy tunnelspecified
split-tunnel-network-list value TunnelSplit1
Thanks.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide