11-18-2004 11:18 AM
We have a Cisco 3640 with a MICA-6DM for our users to dial in remotely.
It has been upgraded to run the 12.2(26) IOS.
After 15 minutes or so the call just drops regradless of activity. All of the call timers are set for much longer than that.
There have been some changes several minor (updates to IP addresses for services) and 1 major one upgrading the IOS from 11.3(10).
If the config is needed please let me know and I will put that up. I have no idea at this point what could be causing the issue.
11-18-2004 11:29 AM
This website may be able to help out in troubleshooting this problem. There are several utilities that can be used to get a better picture of what is going on. I would start with processing the modem log. That should decrypt the reason for the call be disconnected and give a good place to start from.
http://cosi-nms.sourceforge.net/cgitools/dr_mdm/
HTH
Steve
11-18-2004 11:42 AM
Anything I should be looking for in the output from there, as I haven't really seen anything that stands out as an issue.
11-18-2004 11:59 AM
[0](0x7F06) 3 ( 4.11%)
[0](0x8103) 1 ( 1.37%)
[0](0x8220) 41 ( 56.16%)
[0](0xDF00) 25 ( 34.25%)
[0](0xDF06) 3 ( 4.11%)
[1](0x7F06)[0] During call setup, CSR affected
[1](0x7F06)[2] Network indicated
[1](0x8103)[0] In data mode, received data flushed, CSR not affected
[1](0x8103)[1] Condition reported by DSP
[1](0x8103)[2] Too many retrains (S40) or speedshifts. Bad line or remote disconnect
[1](0x8220)[0] In data mode, received data flushed, CSR not affected
[1](0x8220)[1] Local EC condition
[1](0x8220)[2] Received DISC, normal LAPM termination
[1](0xDF00)[0] In data mode, transmitted data flushed, CSR not affected
[1](0xDF00)[2] Non-specific
[1](0xDF06)[0] In data mode, transmitted data flushed, CSR not affected
[1](0xDF06)[2] Network indicated
11-18-2004 07:45 PM
Can you please post the running config?
sh run / sh ver / sh modem ver
Also can you post the output of "sh dialer asyn x" where x is the modem that has an active call onit.
Thanks,
Mak
11-19-2004 11:04 AM
Running Config (minor edits)
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname dial
!
boot system flash flash:c3640-d-mz.122-26.bin
clock timezone Indiana -5
ip subnet-zero
!
!
!
ip dhcp-server 10.0.x.x
ipx routing 12345678
async-bootp gateway 10.2.x.x
async-bootp dns-server 10.0.x.x
async-bootp nbns-server 10.0.x.x
isdn switch-type primary-dms100
!
controller T1 0/0
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 0/1
framing esf
linecode b8zs
pri-group timeslots 1-24
!
!
!
interface Loopback0
ip address 10.255.x.x 255.255.255.0
ipx network 12345678
!
interface Loopback1
ip address 10.x.x.x 255.255.255.0
ipx network 12345678
!
interface FastEthernet0/0
ip address 10.2.x.x 255.255.255.0
ip helper-address 10.0.x.x
duplex auto
speed auto
ipx network 12345678
!
interface Serial0/0:23
ip unnumbered Loopback0
encapsulation ppp
dialer rotary-group 0
dialer-group 1
ipx network AAAAAAAA
isdn switch-type primary-dms100
isdn not-end-to-end 56
isdn incoming-voice modem
no cdp enable
!
interface Serial0/1:23
no ip address
encapsulation ppp
dialer pool-member 2
isdn switch-type primary-dms100
isdn incoming-voice modem
ppp authentication chap
!
interface Group-Async1
ip unnumbered FastEthernet0/0
ip helper-address 10.0.x.x
encapsulation ppp
dialer in-band
dialer idle-timeout 1800
async default routing
async mode interactive
ipx ppp-client Loopback0
peer default ip address dhcp
ppp authentication pap chap
group-range 33 56
!
interface Group-Async2
physical-layer async
no ip address
encapsulation slip
!
interface Dialer0
ip unnumbered FastEthernet0/0
encapsulation ppp
dialer in-band
dialer idle-timeout 1800
dialer-group 1
peer default ip address dhcp
ppp authentication pap chap callin
ppp multilink
!
interface Dialer1
ip unnumbered Loopback1
encapsulation ppp
dialer in-band
dialer map ip 10.x.x.x name
dialer map ip 10.x.x.x name
dialer map ip 10.x.x.x name
dialer map ip 10.x.x.x name
dialer map ip 10.x.x.x name
dialer-group 2
ppp authentication chap
ppp multilink
!
interface Dialer2
no ip address
no cdp enable
!
interface Dialer10
description Dial in for ISDN Router
ip unnumbered Loopback1
encapsulation ppp
dialer remote-name Rd
dialer hold-queue 10
dialer-group 1
no peer default ip address
ppp authentication chap
!
router eigrp 100
redistribute connected
network 10.0.0.0
auto-summary
!
ip default-gateway 10.2.x.x
ip classless
ip route 0.0.0.0 0.0.0.0 10.2.x.x
no ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
dialer-list 1 protocol netbios permit
dialer-list 2 protocol ip permit
dialer-list 2 protocol ipx permit
!
!
ipx router eigrp 100
network AAAAAAAA
network BBBBBBBB
log-neighbor-changes
!
!
!
tacacs-server host 10.0.x.x single-connection
tacacs-server directed-request
tacacs-server key
!
line con 0
password
line 33 56
modem InOut
rotary 1
transport input telnet
autoselect during-login
autoselect ppp
line aux 0
transport input all
line vty 0 4
password
!
end
11-19-2004 11:06 AM
Show Version:
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3640-D-M), Version 12.2(26), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Sat 31-Jul-04 01:09 by eaarmas
Image text-base: 0x60008930, data-base: 0x60B78000
ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
fnb-koko-dial uptime is 5 weeks, 4 days, 19 hours, 47 minutes
System returned to ROM by reload
System image file is "flash:c3640-d-mz.122-26.bin"
cisco 3640 (R4700) processor (revision 0x00) with 44032K/5120K bytes of memory.
Processor board ID 17882425
R4700 CPU at 100Mhz, Implementation 33, Rev 1.0
MICA-6DM Firmware: CP ver 2730 - 5/23/2001, SP ver 2730 - 5/23/2001.
Bridging software.
X.25 software, Version 3.0.0.
Primary Rate ISDN software, Version 1.1.
1 FastEthernet/IEEE 802.3 interface(s)
48 Serial network interface(s)
24 terminal line(s)
2 Channelized T1/PRI port(s)
DRAM configuration is 64 bits wide with parity disabled.
125K bytes of non-volatile configuration memory.
32768K bytes of processor board System flash (Read/Write)
Configuration register is 0x2102
Show Modem Version
Slot 1:MICA-6DM Firmware, Source - IOS
CP ver 2730 - 5/23/2001, CheckSum BCCEB316.
SP ver 2730 - 5/23/2001.
MICA 0: HW Version 1.0, Serial Number 15537939.
MICA 1: HW Version 1.0, Serial Number 15537381.
MICA 2: HW Version 1.0, Serial Number 15535926.
MICA 3: HW Version 1.0, Serial Number 15537930.
MICA 4: Not Installed.
11-19-2004 11:21 AM
As38 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (3600 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Time until disconnect 3385 secs (rudyki)
Dial String Successes Failures Last DNIS Last status
I modified the timer to 3600 last night to try and see what that did...
It looks like the timer runs no matter what. That connection has a ping -t running on it and the disconect timer is going.
11-19-2004 12:10 PM
I think I have it figured out.
The Ansych Interface did not have a dialer group attached, and was not finding any intresting traffic as a result to rest the timer.
I suppose the better question is why did it work before.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide