cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

FMC 7.0.1 - Adding Trusted CA Cert results in empty entry

mattw
Beginner
Beginner

Hi all,

I'm trying to add a CA certificate to my FMC at Objects > PKI > Trusted CAs > Add Trusted CA

I give it a friendly name and then paste in the Base-64 certificate info.

No error messages and the certificate import seems to work fine.

However, when I look at the contents of the certificate, there are no details for the issuer or subject??

The serial number and fingerprints are there.

I've tried with my own internal CA and also with a known good certificate (Cisco Umbrella) and I get the same result.

Also, when I take the same Base-64 text and save it as a .cer file, when I open the file, the certificate details window shows all the details you would expect to see, so it looks like the issue is with the FMC??

Please refer to the attached screenshots.

Could this be a bug? Am I doing something wrong?

Anybody else running 7.0.1 able to try importing a CA trusted cert?

Any help is greatly appreciated!

Many thanks in advance,

Matt.

1 REPLY 1

mattw
Beginner
Beginner

Although this is weird, I just discovered it doesn't actually matter for me right now as when using a private CA, the root CA is installed as part of the certificate enrollment process so it's still being pushed to the FTD and used correctly.

If I had a genuine need to install a CA cert to enable the FMC to trust some other identity certificate, there might be an issue....

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: