cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
617
Views
0
Helpful
1
Replies

pptp vpn routing

gcrisenbery
Level 1
Level 1

I have setup a pptp vpn for windows clients to connect to it works if I give them and ip address on a separate subnet (192.168.12.x) from the subnet they need to access (192.168.1.x) however they need to check use remote gateway on remote network on the windows client for this to work, this isn't acceptable according to the boss man, neither is a batch file to add routes to the windows machines. If I give the vpn clients address on the 192.168.1.x network I can ping the router interface and other subnets but nothing else on the 192.168.1.x which is the only network vpn clients need to access. Is this a NAT or routing issue? how do I get around it. I'll post some relevant parts of my config.

interface Virtual-Template1
ip unnumbered GigabitEthernet0/0.12 (if I change this to 0.1 and the local pool to something on 1.x I can't get to stuff on the 1.x network)
ip nat inside
ip virtual-reassembly
peer default ip address pool dial-in
ppp encrypt mppe auto required
ppp authentication ms-chap ms-chap-v2

interface GigabitEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.1.5 255.255.255.0
ip access-group 102 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1300
no cdp enable
!
interface GigabitEthernet0/0.12
encapsulation dot1Q 12
ip address 192.168.12.5 255.255.255.0
ip helper-address 192.168.1.55
no ip unreachables
ip nat inside
ip virtual-reassembly
no cdp enable
!

ip local pool dial-in 192.168.12.100 192.168.12.200
!

interface GigabitEthernet0/1 (outside interface
ip address 74.x.x.x 255.255.255.240
no ip redirects
no ip unreachables
no ip proxy-arp
ip verify unicast reverse-path
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
no mop enabled

1 Reply 1

gcrisenbery
Level 1
Level 1

Never mind I fixed it with the ip proxy-arp command