cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
968
Views
0
Helpful
1
Replies

Providing IP address to a dialup client on Cisco 2610XM router

l.luong
Level 1
Level 1

Hi,

I have an application where as I need to use a Cisco 2610XM router to provide a DHCP IP address to a dialup client.  The scenario is this: a remote workstation dial the Cisco 2610XM router with an external modem through an async serial port.  When I configured the line for "exec", I was able get to the username/password prompt and then get into the router. However, if I configure "no exec" on line x, I got nothing after the modem answered. I appreciate any help I can get.

Thanks,

sho run
Building configuration...

Current configuration : 1411 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname EIDS-RTR
!
enable secret 5 $1$8/Fv$sZp0KLEMiX23ifRPunzzi/
!
username N30ncamel privilege 15 secret 5 $1$WL/8$zRyAbfz8zaZ3mwSNUsmsa/
username EIDSTEST password 0 123456
ip subnet-zero
!
!
ip dhcp excluded-address 10.83.130.1 10.83.130.99
ip dhcp excluded-address 10.83.130.120 10.83.130.254
!
ip dhcp pool TEXAS
   network 10.83.130.0 255.255.255.0
   default-router 10.83.130.1

#sho run
Building configuration...

Current configuration : 1414 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname YYYY-RTR
!
enable secret 5 $1$8/Fv$sZp0KLEMiX23ifRPunzzi/
!
ip subnet-zero
!
!
ip dhcp excluded-address 10.83.130.1 10.83.130.99
ip dhcp excluded-address 10.83.130.120 10.83.130.254
!
ip dhcp pool XXXX
   network 10.83.130.0 255.255.255.0
   default-router 10.83.130.1
!
!
!
!
!
interface FastEthernet0/0
ip address 10.83.130.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
physical-layer async
no ip address
encapsulation ppp
peer default ip address pool DIALUP
ppp authentication pap
!
interface Serial0/1
physical-layer async
no ip address
encapsulation ppp
peer default ip address pool DIALUP
ppp authentication pap
!
ip local pool DIALUP 10.83.130.200
ip classless
ip http server
!
!
!
line con 0
exec-timeout 0 0
login local
line 1
flush-at-activation
login local
modem InOut
modem autoconfigure type default
no exec
transport input all
transport output telnet
stopbits 1
speed 115200
flowcontrol hardware
line 2
flush-at-activation
login local
modem InOut
modem autoconfigure type default
transport input all
transport output telnet
stopbits 1
speed 38400
flowcontrol hardware
line aux 0
line vty 0 4
login
!
!
end

R#

1 Reply 1

Juan Perez
Level 1
Level 1

Hi,

Is the problem with IPCP pool or with Async access? In order to let remote modem users connecto to this router you would need to add "exec", by using "no exec" you are restricting incoming calls over specified lines. Furthermore I would recommend addind "async mode dedicated" under Serial interfaces. Now, your IPCP pool named "DIALUP" (which is different from DHCP pool) has only 1 IP address for assignment (10.83.130.200), you should consider adding at least another one:

ip local pool DIALUP 10.83.130.200 10.83.130.201

Here is a document for reference, you will find more info about IP address assignment for Dialup clients:

http://www.cisco.com/en/US/docs/ios/12_1/dial/command/reference/drdrmupp.html#wp1017602

Regards!