02-21-2005 03:16 PM - edited 02-21-2020 01:37 PM
Hi is it possible to use a 2600 or 1700 to create VPN's? I would have about 2 routers connecting in and 2 clients. if so is the any config examples?
Thanks
Gus
02-24-2005 08:52 PM
There's lots of sample configs here:
Specifically, the following one looks like what you want:
http://www.cisco.com/en/US/tech/tk583/tk372/technologies_configuration_example09186a0080094685.shtml
02-25-2005 07:56 AM
here is a simple basic config that might help you, just remember you will have to change it a little for your 2600. This will work on 1700 directly. Also this is used for connecitons over dsl, cable and so forth, private lines would be the tunnel source if you are using them.
!
crypto isakmp policy 25
encr 3des
hash md5
authentication pre-share
crypto isakmp key
!
!
crypto ipsec transform-set ANES esp-3des esp-md5-hmac
mode transport
!
crypto map GRE 50 ipsec-isakmp
description Tunnel
set peer destination host ip
set transform-set ANES
match address -GRE
!
!
!
interface Loopback0
description Connectionless IP Circuit for
ip address
!
interface Tunnel0
description GRE Tunnel to destination Tunnel #
bandwidth 1024
ip address
ip mtu 1440
ip hello-interval eigrp 1 4
ip hold-time eigrp 1 10
ip route-cache flow
no ip route-cache
no ip mroute-cache
tunnel source Ethernet 0
tunnel destination
crypto map GRE
!
!
!
interface Ethernet0
description Public Network Interface to
ip address
no ip directed-broadcast
ip access-group 115 in
no shutdown
crypto map GRE
!
!
interface FastEthernet0
description Protected Network
ip address
no ip directed-broadcast
no shutdown
!
!
!
ip route
ip route
!
!
access-list 3 remark Telnet Access to VTY's
access-list 3 permit
access-list 3 permit
!
!
!
ip access-list extended GRE
remark Encrypt GRE Traffic from Remote Site to host site
permit gre host
!
!
!
access-list 115 remark Permits and Established from the Internet
access-list 115 permit icmp any host
access-list 115 permit icmp any host
access-list 115 permit icmp any host
access-list 115 permit icmp any host
access-list 115 permit icmp any host
access-list 115 permit icmp any host
access-list 115 permit icmp any host
access-list 115 permit tcp host destination host
access-list 115 permit udp host destination host host
access-list 115 permit gre host destination host host
access-list 115 permit esp host destination host host
access-list 115 deny ip 127.0.0.0 0.255.255.255 any
access-list 115 deny ip any any
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide