Showing results for 
Search instead for 
Did you mean: 

Unable to install package for SSL VPN on 2901 router

Hi all,


This is driving me crazy. I'm trying to setup my 2901 router as a Web VPN server (or SSLVPN) so users can use Cisco AnyConnect Secure Mobility Client . I've followed this guide

but when I try to install this package "anyconnect-win-3.1.05160-k9.pkg"  using the command

"webvpn install svc flash:webvpn/anyconnect-win-3.1.05160-k9.pkg seq 1" I get the error "SSLVPN Package SSL-VPN-Client (seq:1): installed %%Error: No such file or directory". I also tried using an FTP server in case I don't have enough memory on the flash card (it's a 128 MB) so I did

"webvpn install svc seq 1" I get this different error "SSLVPN Package SSL-VPN-Client (seq:1): installed %%Error: Invalid Archive" happens even though I have "122421248 bytes available (134066176 bytes used)" of free flash space. I've read all threads but I don't think my problem is related with flash space. I'm running IOS "c2900-universalk9-mz.SPA.151-4.M7.bin" with this setup

Cisco CISCO2901/K9 (revision 1.0) with 466944K/57344K bytes of memory.
Processor board ID XYZ
1 DSL controller
1 Ethernet interface
3 Gigabit Ethernet interfaces
4 ISDN Basic Rate interfaces
1 ATM interface
2 terminal lines
1 Virtual Private Network (VPN) Module
1 Internal Services Module (ISM) with Services Ready Engine (SRE)


Can anyone kindly explain me how to install that bloody file? I'm out of ideas. :(

What I am doing wrong?









Marvin Rhoads
VIP Community Legend

Start off by doing a simple ftp copy of the pkg file to flash:webvpn directory. Then run the "webvpn install" command.

It's a bit misleading how they translate what CCP does in the link you provided to the cli configuration. They show the resultant configuration which, in the case of the operation you're asking about, is more of the actual binding of the pkg file to the webvpn service - not the actual file transfer.

Hi Marvin,

Thanks for your reply. Unfortunately copying the file to the flash:/webvpn directory didn't work. It has to be copied to the ROOT directory (see my answer to johnlloyd_13 thread above)

Hope this helps someone!




Could you try putting a "/" after flash:

webvpn install svc flash:/webvpn/anyconnect-win-3.1.05160-k9.pkg


Hi John,


Thanks for taking your time and answering to me. I got it working!!

The correct process was:

1.- Copy the .pkg into the ROOT flash directory:

  •  #copy ftp: flash:

2.- Make sure there's enough room to accomodate the installation package. At least same amount of free space as the actual size of the .pkg file copied on the step before. Reason being is that the IOS copies the file to the flash:/webvpn directory when issuing the below command.

3.- Install the .pkg

  • (cfg)#webvpn install svc flash:anyconnect-win-3.1.05160-k9.pkg seq 1
  • (wait for a couple of seconds...)
  • SSLVPN Package SSL-VPN-Client (seq:1): installed successfully

  • Excitement!!!

4.- Follow any of these links:




i'm glad you've solved the issue and able to share the resolution.

Thanks indeed.

I had it 90% correct. We don't see a lot of IOS router SSL VPN configuration via cli these days.

Please rate any answers that are helpful.


Hi everyone,


I'm getting the same issue with the last release of AnyConnect 4.6 on a Cisco 897 Router with the advipservices and IOS 15.6 or 15.5 version.


I was able to install it correctly only with the 15.4 IOS version.


Can anyone help me with this issue? The procedure described from Alvaro unfortunately doesn't work for me.


Thanks in advance



I found what the issue was, thanks to this post:


I discover my router was running out of memory while installing the SSL VPN Package, I had to free up some memory on the router to install the package successfully.


Thank you,

Recognize Your Peers
Which of these topics should we host an event in the Community?

Top Choice: pxGrid (35%)

Content for Community-Ad