Showing results for 
Search instead for 
Did you mean: 

VPN Agent Service not responding?

Installed Cisco AnyConnect VPN on a Windows 7 Professional laptop. However, as soon as I start the application, I receive the error:

"The VPN Agent Service is not responding. Please restart this application after a minute."

No matter how many times I restart the application, or uninstall and reinstall, I still receive this error. I really need help to solve this problem! Any help will be greatly appreciated. Thank you.



Hi Sanjay,

Assuming that you are using the latest anyConnect application, few question here:

-- did you install it as an administrator AND running it as an administrator?

-- make sure the antivrus or any 3rd party firewall is not causing the issue.

-- And when u uninstall, make sure all the files from AnyConnect installation directory are deleted (if not, delete them manually).

Let me know hot it goes.




I was able to resolve this by restarting the "Cisco Security Service" on Windows 8.  See attached screen shot of specific service.


Your tip work for me, thanks mate.

This resolution worked for me. Thank you.


I know this message is old, but I am desperate.  Anyone who can help, please do.  I tried to follow the screenshot, but the "Cisco Security Service" doesn't show up at all to start or restart.  I see the Cisco AnyConnect Secure Mobility Agent but none of the other Cisco services that show in your screenshot.  


Anyone have any thoughts?

I tried net start Cisco Security Service

I tried net start ciscod.exe


I tried 

netsh winsock reset catalog

netsh int ip reset reset.log

Cisco Employee

Hey Sanjay,

The error message you've mentioned is normally seen when certain features like SBL or Always on is enabled. Do you have any of these features enabled? Also could you try downloading the standalone Anyconnect version with the DART bundle and installing that? For more information regarding DART please refer to the following link:

Once we have the DART files please open a TAC case and attach the DART files to the case. It'll be easier to diagnose why you are getting this error message.




It sounds like you need to start your VPN service. Open Services (under Administrative Tools in Control Panel in XP, not totally sure where in 7...) and scroll down to Cisco AnyConnect VPN Agent and start that. You may need to change its Startup Type to Manual or Automatic if it is Disabled before it will allow you to start it. Hope that fixes things for you.


I'm getting this same error on Mac 10.7 Lion:

The VPN agent service is not responding.  Please restart this application after a minute.

How do i fix this?



While using CISCO ANYCONNECT VPN client, i get following message

The VPN agent is not responding.Please contact your IT administrator for assistance.

i find cisco services is running fine. I un-installed and installed many  times but same issues. plz suggest what need to be done.

Also, I sanned the Ful machine i could not find what is the problem it it?


This worked for me in this case


This is a perfect response and it worked for me.

Thank god, I referred to this post before my attempt to uninstall and reinstall the app.


this fixed, thanks!

I had this problem,.. What happened was I had reverted the ASA back to a previous configuration where Anyconnect 2.5 was at the top of the list for web-deployment and I inadvertently downloaded it,.. The next time I tried connecting with the already installed version 3.1 I got the VPN agent is not responding message even though it showed running in services.  So I believe the two versions were competing for the socket at the same time (who knows) but I uninstalled both versions, rebooted my WIndows 8 laptop and reconnected to the WebUI and pulled 3.1 down fresh again.... And Viola!  It works again with no errors.  I did not do anything else so I am 100% sure for me that it was the competing versions trying to grab the service


The AnyConnect VPN service does not start automatically. The error message "

VPN Service not available. The VPN agent service is not responding. Please restart this application after a minute

" means, that the Cisco AnyConnect VPN service currently is not running. This could be caused by a Windows boot accelerator software, that modifies the start order of the Windows services in a way, some services cannot be started anymore. In the past such problems were caused by e.g.

Lenovo Rapid Boot

. After uninstalling such softwares, the problem should be solved.

Content for Community-Ad