cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

VPN User cannot browse internet

atrzonkowski
Beginner
Beginner

I've recently found myself working with an ASA 5505 and setting it up so that remote users can connect via VPN. In that part I've managed to muddle through. Users can connect and authenticate. Once that connection has been established they can no longer browse the web. I would like to ensure that they use the distant end web instead of the local one.I think I'm close but I'm fairly stuck. Any help would be greatly appreciated.

ASA Version 7.2(4)
!
hostname Ex
domain-name Ex
enable password encrypted
passwd encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!

ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
domain-name Ex
same-security-traffic permit intra-interface
access-list inside_nat0_outbound extended permit ip any 192.168.2.0 255.255.255.248
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool RemoteDHCP 192.168.2.2-192.168.2.7 mask 255.255.255.248
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
nat (outside) 1 192.168.2.0 255.255.255.248
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-AES-256-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
telnet timeout 5
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
ssh version 2
console timeout 0
dhcpd dns 209.18.x.x 209.18.x.x
dhcpd auto_config outside
!
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd enable inside
!

group-policy 1 internal
group-policy 1 attributes
dns-server value 209.18.x.x 209.18.x.x
vpn-tunnel-protocol IPSec
default-domain value Ex
username  password encrypted privilege 15
tunnel-group 1 type ipsec-ra
tunnel-group 1 general-attributes
address-pool RemoteDHCP
default-group-policy 1
tunnel-group 1 ipsec-attributes
pre-shared-key *
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
  message-length maximum 512
policy-map global_policy
class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context

1 ACCEPTED SOLUTION

Accepted Solutions

Hi,

Yes, you are correct. The client is not receiving anything. Please add this command "crypto isakmp nat-t" and then connect the client. Make sure that you reconnect the client after adding this command if the client is connected at the time of adding the command.

If this doesnt work, send me the output of "sh cry ipsec sa".

Mitesh

View solution in original post

12 REPLIES 12

slmansfield
Enthusiast
Enthusiast

It looks like you're tunneling all traffic from the VPN client, including Internet traffic.  You can either configure split tunneling, whereby Internet traffic would not be sent through the VPN tunnel, or you could route Internet traffic through your central site and return it to the VPN client.

Here is a URL describing how to configure split tunneling on the ASA.  HTH

http://www.cisco.com/application/pdf/paws/70917/asa-split-tunnel-vpn-client.pdf

If I understand correctly (and I'm honestly not sure I do) if I enable split tunneling web traffic would use the local connection instead of the remote sites. Is that correct? If so, could you elaborate on your second option of routing the traffic through the central site?

I appreciate the help!

That is correct.  If you would prefer that the remote client use its own Internet connection to access the Internet directly instead of through the VPN then

you could implement split tunneling.

Split tunneling could make the PC more vulnerable to Internet threats.  If that is a concern, you may want to configure your VPN client to access the Internet through the VPN tunnel.

Running VPN traffic through your central site means that the ASA has a default route to the Internet.  If you want the Internet traffic to be sent to/from the ASA, you can route traffic between its interfaces.  It looks like you are doing the intra-interface routing already, but I don't see a default route on the ASA.

Here is another URL that describes "VPN on a Stick", where the ASA is the endpoint for VPN and for Internet access to/from VPN clients.

HTH

http://www.cisco.com/application/pdf/paws/67986/pix7x-asa-client-stick.pdf