cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
72673
Views
1
Helpful
20
Replies
demitri.p1
Beginner

Windows 10 keeps disconnecting VPN after screen lock

Hi There,

I'm experiencing a very annoying Win 10 + Cisco Any Connect Secure Mobility Client issue. I get VPN disconnected each time I lock my screen (even locking for a second and loging in back).

It's on wired Ethernet connection and I've disabled "Allow the computer to turn off this device to save power". Still no positive result.

 

Any ideas on this please? Thank you.

 

Cisco Any Connect Secure Mobility Client 3.1.05160.

All power options like "sleep", "hibernate", "disable hard drive after" are switched off.

Ethernet and VPN have "Private network" option.

20 REPLIES 20
LJ Gabrillo
Contributor

This is most likely not a Cisco AnyConnect issue, but more of a Windows feature
Try searching for "software closes when i lock windows"

LINK: http://bit.ly/1Nz2zn7

I have the same problem. From the message history in AnyConnect I can see AnyConnect is disconnected after login from a lock screen. I also have a problem with Start Before Logon. After logon in Windows AnyConnect is disconnected and needs to reconnect

Using version 3.1.10010.

This discussion has been reposted from Additional Communities to the VPN community.

raa
Beginner
Beginner

I had the same problem when I first installed Windows 10 using version 3.1.10010. I traced it down to the "Start VPN before user logon to computer" setting. When this is set, the VPN disconnects every time the computer is locked. Try clearing the checkmark - it resolved the problem for me.

As another user stated, there is a problem with the start before logon component on windows 10 too. I can connect the VPN at the logon screen, but as soon as I actually log on to the computer, the VPN is disconnected. I suspect the two problems are related. For now, I have instructed out Win10 users not to use the start before logon feature.

Hope this helps,

/Rasmus

Hi Rasmus,

Thank you for reply. I don't see "Start VPN before user logon to computer" option in  Cisco Client's settings. There are only 2 checkboxes under Preferences tab.

Maybe all others are hidden by my employer or something else. Do you know can "Start VPN before user logon to computer" option be disabled in config files?

After unchecking "Start VPN before user logon to computer" setting, connection isn't disconnected everytime I unlock Win10 computer. With this setting unchecked, "start before login module" isn't loaded.

This way I don't have to reconnect VPN everytime I unlock screen (connection is active until unlock), but it would be very nice if I could login to AnyConnect before Windows login. I have same issue with two Win10 computers.

Brgds, Erik

karl.foley
Beginner

I have the same issue with the v4.2.00096 client running on Windows 10 v1511 (Threshold2).

If I uninstall the "Start before logon" component, I can lock and unlock without losing the VPN connection.

Uninstalling "Start before logon" component helps with VPN disconnects while unlocking computer, but this isn't good solution for me, while i would need to connect VPN before Windows logon.

With "Start before logon" component installed, I can connect VPN before logon to Windows, but connection gets disconnected before i can proceed logon to windows. I haven't found any way to use "Start before logon" correctly on Windows 10.

I understand what you're saying!

We use SBL fine with Windows 7, but not Windows 10.

Do Cisco officially support AnyConnect with Windows 10 yet?

I'm raising this with Cisco as a TAC case.

I've raised this as TAC case #537158145 and have been told this has been raised as a bug, both against Cisco and Microsoft.

Cisco issue is CSCuv74296, and Microsoft bug ID is #4507924 "Cisco AnyConnect PLAP does not work on Windows 10".

No ETA for a fix I am afraid.

Now i got AnyConnect to work correctly on Windows 10, with "Start before logon" enabled. No more disconnects while unlocking and Windows login works with SBL.

I'm not sure if this issue was fixed in AnyConnect 3.1.13015 or by latest MS patches.

AnyConnect 4.2.01035 Works with Windows 10 also the Start Before Login

Did they resolve the issue in the update 3.1.13015?

I tried SBL with the new version 3.1.13015 on Windows 10 and I can't get SBL prompt to appear at the login screen.

Has anyone seen this work on Windows 10?