Showing results for 
Search instead for 
Did you mean: 

Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr

Ask Me Anything – How to Enable Network Connectivity to Remote Workers

Convert 1142 from IOS to LAP (IP Issue)



I've been converting a lot of 1142s latley and everything have worked well until now when I've encontered a strange issue.

Fist I login to the autonomous AP and backup the configuration, just in case I need to roll back for some reason. Then I issue the command:
archive download-sw /overwrite tftp://<TFTP-Server>/c1140-rcvk9w8-tar.152-4.JA1.tar

I then hit reload... and the LAP boots. First it gets an IP from DHCP. It joins the WLC and begins downloading the latest firmware version. After that it boots again but now strange things happen. Once the boot for the 2nd time they go back to their old IP (that they used prior to being LAP) and with static configuration. Since they do that they do not rely on DHCP no more and wont join the controller becuse of that. Does anyone have any idea how they can switch back to use their old IP?


They are sill lightweight though (their name is AP<MAC-ADDRESS>).




Everyone's tags (1)
Hall of Fame Master

Prior to the conversion, you

Prior to the conversion, you should either erase the configuration back to default or change the IP setting from static to DHCP. So when you convert them, they will use DHCP. You do need to have DHCP on that subnet. Maybe use the WLC as a DHCP server for the access points for the mean time so they can join and then you would have to manually configure the static address. You have a different issue though... Because once an AP joins and downloads the code and reboots, it should know of the WLC IP address and there is no need for using option 43. You will probably need to console into the AP and provide the full output from when the archive command was issued.
*** Please rate helpful posts ***

Thanks for replying!Yes, I

Thanks for replying!

Yes, I managed to solve the ones I had already had this happen to with a factory reset and the rest I mananaged to fix by eraste starup-config and write default. It's strange though becuse I have done this very same way with 1142s in the past and it has always worked. The WLC is on a different subnet, and it's not used as DHCP server for the APs.

Once I did what I described in the OP they reload, get IP from the DHCP server with Option 43, they reload, join the WLC, downloads firmware, reboots and then; upon the second reboot they retain their original static IP and are again unable to join the WLC.

Strange indeed. I was not able to get a console on them to see what happened as I did everything from remote. I'll stick to resetting them to default before I download the recovery :)

Hall of Fame Master

There are other ways than

There are other ways than using option 43... you can use DNS or UDP broadcast forwarding to help the AP's find the WLC.

*** Please rate helpful posts ***
CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey