cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

299
Views
20
Helpful
6
Replies
Beginner

Problem connecting a device to iPSK network

Hi All,

 

I'm testing a new iPSK based IoT wlan on a WLC8540 (8.5.140.0) and using an ACS 5.8 radius server for authentication.

The wlan works successfully with a laptop and Android phone but does not work with a particular air sensor we have.

The air sensor works fine with a regular PSK wlan but fails to associate to the AP using the iPSK configuration.

 

Below are some screen shots from the WLC troubleshooting tools and I've also attached some debug client info.

 

Anyone any suggestions on what i could be doing wrong?

Any help would be much appreciated.

 

thanks,

Ciarán

 

iPSK Awair1.PNGiPSK Awair2.PNG

 

 

 

6 REPLIES 6
Hall of Fame Master

Re: Problem connecting a device to iPSK network

That’s pretty tough since you identified that only one type of devices fail. Have you looked at the radius logs to see what it shows?
-Scott
*** Please rate helpful posts ***
Beginner

Re: Problem connecting a device to iPSK network

Hi and thanks for for getting back to me.

 

No radius logs at all for the device in question. No record of it failing the initial MAC authentication. It appears to be failing to get to the 'Associated' client stated.

When I look at the client on the WLC, the username is blank. Could it be something like, it's not sending it's MAC address as a client username for MAC authentication (Sorry my understanding of every step of the process is a little weak).

 

thanks again.

Hall of Fame Master

Re: Problem connecting a device to iPSK network

>From my experience, it seems like how the device is trying to associate is the problem and not your wireless. Can the issue be with special characters you have defined in the psk?
-Scott
*** Please rate helpful posts ***
VIP Advocate

Re: Problem connecting a device to iPSK network

Just to confirm, if you connect to the same SSID with the same iPSK with your Android device, the connection is successful?
You did add the correct MAC address of the sensor to your Radius server? Your Radius server must log something, otherwise the SSID/Radius configuration is wrong.
Link to deployment guide (skip the network policies part, that's optional):
https://www.cisco.com/c/en/us/td/docs/wireless/controller/technotes/8-5/b_Identity_PSK_Feature_Deployment_Guide.html
Beginner

Re: Problem connecting a device to iPSK network

I think I have it working now. I removed and re-added the MAC address from the access policy on the ACS and it worked.

I confirmed before removing it that it was configured identically to the other entries in the authroisation rule of the access policy. But when I re-added it, it just started to work, I can't explain why but it's something i should have tried sooner!

 

thanks for all your help.

Ciarán

 

Hall of Fame Master

Re: Problem connecting a device to iPSK network

That’s great that you got it to work. Funny thing is when I have issue with anything on radius/Tacacs i usually delete the object the re add it. I don’t even bother to make changes to the object.
-Scott
*** Please rate helpful posts ***
CreatePlease to create content
Content for Community-Ad

August's Community Spotlight Awards