Showing results for 
Search instead for 
Did you mean: 
VIP Advisor

2600 series boot problem upon controller upgrade

- I recently (tried) upgrading a 5508-wlc  from release to ; which worked but some
2600 series ap could not boot. The following output was observed :

Ethernet speed is 1000 Mb - FULL Duplex

Loading "flash:/ap3g2-k9w8-mx.152-2.JA1/ap3g2-k9w8-mx.152-2.JA1"...flash:/ap3g2-k9w8-mx.152-2.JA1/ap3g2-k9w8-mx.152-2.JA1: no such file or directory

Error loading "flash:/ap3g2-k9w8-mx.152-2.JA1/ap3g2-k9w8-mx.152-2.JA1"

Loading "flash:/ap3g2-k9w8-mx.152-2.JB/ap3g2-k9w8-xx.152-2.JB"...uncompress: Unknown mzip segment type: 2

Error loading "flash:/ap3g2-k9w8-mx.152-2.JB/ap3g2-k9w8-xx.152-2.JB"

Interrupt within 5 seconds to abort boot process.

Boot process failed...

If you manually boot :


then the AP can boot, Note the subtle difference in the image names :  ap3g2-k9w8-mx.152-2.JB versus ap3g2-k9w8-xx.152-2.JB

Anyone else seen such issues, it's harsh because the AP needs to be serviced from FAB-locations. Simply power cycling does not
help and console access is needed. Are there any subtle tricks to get the AP sooner online ... ?


Amjad Abdullah

The devices that could not boot share same part number with APs that worked correctly after the upgrade?

I think if you can just remove the bad image from the flash that may help. The AP will have only one image then on the flash from which it boots.

You can also try to rest the AP to factory default from the WLC and see if that helps.



Rating useful replies is more useful than saying "Thank you"

Rating useful replies is more useful than saying "Thank you"
Scott Fella
Hall of Fame Master

Well if the AP's can't boot and join the wlc, then you are really in a bad spot. You would have to console into the AP and make the changes.

Sent from Cisco Technical Support iPhone App

*** Please rate helpful posts ***

- True, what interests me more, is how did the ap ever get into this 'configuration' ; I would like to avoid it

for future ap resets (let alone upgrades).


Depends... could be a corrupt image on the WLC base code or if you did a pre image upload to the ap that might of caused it also.  If you didn't do a pre image upload, maybe that is something you need to test and then when the code is uploaded to the AP, you can verify that the image is in flash.  If this happens to all 2600 ap's, maybe you need to upload the firmware on the WLC again as the code has the specific image for the 2600.



Help out other by using the rating system and marking answered questions as "Answered"

*** Please rate helpful posts ***

I did do some image pre-loading in the past. It could be related to this activity. It then remains to be seen
wether the problem, in the end,could be tracked to a cisco bug or some mis-activity on my part. As you point out it would

be very harsh to trace back, when and how the ap got into this state. For the moment I 'repair'(ed) the ap

by manually booting the correct image.Also afterwards a controller upgrade was executed which downloads

a new image to the AP and then the boot var is being set correctly for new boots,(by the upgrade process).

          Hence the AP can again operate after resets (too).


Leo Laohoo
VIP Community Legend

I've seen this before.

My only choice was to delete the full IOS.   In your case, "delete /f /r flash:/ap3g2-k9w8-mx.152-2.JB" and get the AP to download the IOS again.

How is the latter (get the AP to download the IOS again) achieved  when all local OS IOS are deleted ?


Leo Laohoo
VIP Community Legend

How is the latter (get the AP to download the IOS again) achieved  when all local OS IOS are deleted ?

Hold on.  I never recommended you delete ALL the IOS.  My recommendation is to delete the FULL IOS by using the command  "delete /f /r flash:/ap3g2-k9w8-mx.152-2.JB".

This leaves, hopefully, the "rcv" directory in place so when you reboot the AP, the AP will contact the WLC and download again the full IOS. 

Ok, good to know.

Wouldn't it be handy to let the AP always download the OS from the controller

upon boot (and reset). This would avoid such problems and kind of enforce an always-sync state with

the controller. Also argumenting that for instance nowadays with the upcoming of for instance the 3780 which

can be both a switch and a controller (avoiding overloaded network-cap-wap-paths). This may become an even more

feasible or 'practical'  solution in the future ?


Content for Community-Ad