12-04-2024 01:52 PM - edited 12-04-2024 01:53 PM
I am trying to implement the following topology with real devices:
My devices are:
WLC (5520 Series)
Access Points (2600 Series) - Lightweight
Switch (Catalyst 3750 X Series)
I have ran the following configuration on the switch:
interface g1/0/1
switchport mode access
switchport access vlan 60
no shutdown
vlan 60
name Management
vlan 50
name Neurologie
vlan 70
name Laboratorien
interface vlan 60
ip address 192.168.0.69 255.255.255.192
no shutdown
interface vlan 50
ip address 192.168.0.5 255.255.255.192
no shutdown
interface vlan 70
ip address 192.168.0.133 255.255.255.192
no shutdown
ip dhcp excluded-address 192.168.0.65 192.168.0.69
ip dhcp pool Management
network 192.168.0.64 255.255.255.192
default-router 192.168.0.69
dns-server 8.8.8.8
option 43 hex c0.a8.00.42
ip dhcp excluded-address 192.168.0.1 192.168.0.5
ip dhcp pool Neurologie
network 192.168.0.0 255.255.255.192
default-router 192.168.0.5
dns-server 8.8.8.8
option 43 hex c0.a8.00.42
ip dhcp excluded-address 192.168.0.129 192.168.0.133
ip dhcp pool Laboratorien
network 192.168.0.128 255.255.255.192
default-router 192.168.0.133
dns-server 8.8.8.8
option 43 hex c0.a8.00.42
int g1/0/2
switchport mode access
switchport access vlan 50
int g1/0/3
switchport mode access
switchport access vlan 70
int g1/0/4
switchport mode access
switchport access vlan 60
The access points and the laptop are able to obtain an ip address and its corresponding to their vlan, however the access points cannot seem to find the wlc. Not in Bound state.
*Jul 5 19:37:12.867: %CAPWAP-3-DHCP_RENEW: Could not discover WLC. Either IP address is not assigned or assigned IP is wrong. Renewing DHCP IP.
*Jul 5 19:37:22.983: %DHCP-6-ADDRESS_ASSIGN: Interface BVI1 assigned DHCP address 192.168.0.11, mask 255.255.255.192, hostname AP7c69.f626.5f65
Translating "CISCO-CAPWAP-CONTROLLER"...domain server (8.8.8.8)
This is the management interface on the wlc.
12-04-2024 02:05 PM
Your option 43 is not correct: https://shimi.net/services/opt43/
12-05-2024 08:08 AM
Thank you for your reply, but the following log is still shown : Translating "CISCO-CAPWAP-CONTROLLER"...domain server (255.255.255.255).
12-04-2024 02:14 PM
Not sure if PacketTracer will support option 43 for access points. You better put the AP on the same vlan as the WLC management interface.
12-05-2024 08:07 AM
I am implementing the topology with real devices. Tried to put the access points to the same vlan as the wlc but it didn't work.
12-05-2024 08:36 AM - edited 12-05-2024 08:42 AM
wow...real devices? sorry. Did not realize that. Try to add the WLC statically on the AP for test porpuse
capwap ap primary-base controller-name controller-ip-address
Also make sure you have Lag enabled on the WLC side and trunk mode on the switch side if you intent to work with mode than one Vlan on the WLS
12-05-2024 07:06 AM
1. Wrong option 43 as detailed by @Haydn Andrews
2. Wrong management interface config on WLC:
- subnet mask is 255.255.255.0 instead of 255.255.255.192
- default gateway is 192.168.0.1 instead of 192.168.0.69
12-05-2024 08:06 AM
Thank you for the reply. I did the changes but it still doesn't work. I removed the dns server from the configuration but the same log is tried. Translating "CISCO-CAPWAP-CONTROLLER"...domain server (255.255.255.255). Is there a way to remove the configuration on all devices?
12-05-2024 09:54 AM
What version of software is the WLC running?
Can you ping from the APs to the WLC?
What version of software is currently installed on the APs?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide