Showing results for 
Search instead for 
Did you mean: 

AP 1815w works with an PoE injector but not with PoE from a switch


I have a bunch of 1815W APs that have stopped working when powered by Cisco PoE switches (for example C2960X) but work with an ancient PowerDsine 9001G power injector.

Those APs used to work with the switch, for some reason they failed, so while checking them I connected them to the power injector at home and they work, took them back to the office, connected them to the switch and nothing. They don't boot, nothing happens.

With the injector the log has:

Oct 1 01:44:41 brain: LLDP PoE negotiation START

Oct 1 01:45:14 brain: LLDP PoE negotiation FAILED !!
Oct 1 01:45:14 brain: Power mode: Full-Power, power_detection: DC_adapter(FALSE), 802.3AF_POE(FALSE)


But if I connect PoE switch -> injector -> AP, the AP works and does not show the PoE negotiation FAILED so I don't think this is relevant.


Any ideas?

5 Replies 5

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

Post the complete output to the switch command "sh version".

k365-atkr-r-0a-01#show version
Cisco IOS Software, C2960X Software (C2960X-UNIVERSALK9-M), Version 15.2(7)E2, RELEASE SOFTWARE (fc3)
Technical Support:
Copyright (c) 1986-2020 by Cisco Systems, Inc.
Compiled Sat 14-Mar-20 16:53 by prod_rel_team

ROM: Bootstrap program is C2960X boot loader
BOOTLDR: C2960X Boot Loader (C2960X-HBOOT-M) Version 15.2(6r)E, RELEASE SOFTWARE (fc1)

k365-atkr-r-0a-01 uptime is 29 weeks, 6 days, 16 hours, 35 minutes
System returned to ROM by power-on
System restarted at 06:44:37 est Fri Mar 5 2021
System image file is "flash:c2960x-universalk9-mz.152-7.E2.bin"
Last reload reason: Reload command


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

If you require further assistance please contact us by sending email to

cisco WS-C2960X-48FPS-L (APM86XXX) processor (revision G0) with 524288K bytes of memory.
Processor board ID FCW1929A34C
Last reset from power-on
2 Virtual Ethernet interfaces
1 FastEthernet interface
52 Gigabit Ethernet interfaces
2 Ten Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : AC:7E:8A:0A:7B:00
Motherboard assembly number : 73-15969-02
Power supply part number : 341-0527-01
Motherboard serial number : FOC192788VV
Power supply serial number : DCB192563DY
Model revision number : G0
Motherboard revision number : C0
Model number : WS-C2960X-48FPS-L
Daughterboard assembly number : 73-14200-03
Daughterboard serial number : FOC19292SQE
System serial number : FCW1929A34C
Top Assembly Part Number : 800-41466-01
Top Assembly Revision Number : D0
Version ID : V02
CLEI Code Number : CMMLN00ARB
Daughterboard revision number : A0
Hardware Board Revision Number : 0x12

Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 54 WS-C2960X-48FPS-L 15.2(7)E2 C2960X-UNIVERSALK9-M

Configuration register is 0xF



This is not limited to this switch, it does not works with other non Cisco switches also.


Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

What does the TDR say?

Arshad Safrulla
VIP Advocate VIP Advocate
VIP Advocate

if you are using POE injectors in any POE port, you must remove POE for that port from switch side. Otherwise POE negotiation will not happen properly. 

Also make sure that the POE in the switch is working properly by directly connecting a AP to switch using a patch code. If possible try connecting another POE device to check. Also make sure that you have CDP enabled in the switch ports connecting to the AP's. For 1815w for full functionality you need to have 802.11at(30W) per switchport, if not it will work with 802.11af(15W) but will not be able to provide power to any devices connected to the AP's POE port. 

The switch port is configured correctly, the issue is not the switch. I have tried many switches with the same result.

Basically I pug in a working 1815w to the port, it comes up fine, then I plug this "weird" 1815w to the same port and the switch does not even register anything on the port.

Are they any cli commands I can run on the AP to do some diagnostics of the PoE parts while it is on the power injector?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers