cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1024
Views
0
Helpful
8
Replies

C9115AXI-B / C9800-40 WLC FlexConnect Problem

MasonK
Level 1
Level 1

I'm in the process of creating a wireless management VLAN for our APs, and so am re-IP'ing the access points. Currently they're in VLAN 1 alongside the clients of one of the WLAN's, so I'm putting them into VLAN 109. However when I do so on a test AP, all of the clients suddenly are put into VLAN 109 as well. My configs are as follows:

FlexConfig Policy - VLAN 109 is the Native VLAN. VLAN 1 is configured.

WLAN's - WLAN1 uses VLAN 1 and Local Switching/Association. WLAN2 (Guests) uses Central Switching and works just fine.

Tags - New tags are applied to the AP to use the above policies.

Switchport - Trunk mode, Native VLAN 109, both 109 and 1 are allowed.

 

Any ideas why this might not be working? I followed the below guide to make sure everything's configured as it should be, and it all looks good. I am not able to ping any clients in WLAN1 though, and the MAC table on the switch shows all MACs on that port as being in VLAN 109.

 

https://www.cisco.com/c/en/us/support/docs/wireless/catalyst-9800-series-wireless-controllers/213945-understand-flexconnect-on-9800-wireless.html

 

Operational Config Screenshot:

 

Capture.PNG

8 Replies 8

Hi

  It seems to me that the problem could be related to the Native in the vlan 109.  Can you another vlan on the Policy profile and not configure it as native?

Well in order for the AP to have its IP in a VLAN separate from the WLANs' it needs to be configured that way. In the document I linked that's how Cisco describes it should be done.

Just a suggestion. AP use native vlan to get IP address, as this vlan is the only vlan it knows, it expected the client also get IP on this vlan. 

 I may lose it, the document seems to focus on ssid only. 

 

Arshad Safrulla
VIP Alumni
VIP Alumni

For an AP in FlexConnect local switching mode:

●      Specifying vlan-name = default, client is assigned to VLAN 1

●      Using vlan-id 1, a client is assigned to the FlexConnect native VLAN

 

so go to the policy profile of the SSID in question and do the above mentioned change.

https://www.cisco.com/c/en/us/products/collateral/wireless/catalyst-9800-series-wireless-controllers/guide-c07-743627.html

Got it, thank you. I'll give that a shot and test once I'm back in the office on Wednesday. I'll let you know if it works or not.

Good Morning - I configured that WLAN to use "default" instead of typing "1", however it did not make a difference.

Hi Mason,

Can you do the same changes in the flex profile as well. If not please post the flex and policy profiles attached to the AP.

I am not able to do so in the Flex profile. It only lets me type in a number there, and does not provide a drop-down box to pick options from.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card