cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1345
Views
0
Helpful
4
Replies
Not applicable

Cisco 1852i Access Point not connecting to Controller or DHCP Server

I am trying to get the Cisco 1852AP to receive a DHCP address and as well as talk to the controller but unsuccessful:

I currently have a DHCP Server, WLC and the Cisco 1852AP all connected to my 3750 switch. The DHCP server is in Vlan 210 and the WLC is in vlan 101. I've tried everything from making both the Server and AP interfaces access and trunk ports but keep reciving the following error when consoled into the AP:


"waiting for uplink IP address and reachable default gateway"

I can successfully ping the DHCP server from my Controller

interface GigabitEthernet1/0/1
description WLC
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 101,210
switchport mode trunk
!
interface FastEthernet1/0/4
description Server
switchport access vlan 210
switchport mode access
!
interface FastEthernet1/0/5
description Access Point
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 101,210
switchport mode trunk
no logging event link-status


interface Vlan101
ip address 172.10.108.65 255.255.255.192
ip helper-address 172.10.100.151
no ip redirects
no ip unreachables
no ip proxy-arp
!
interface Vlan210
ip address 172.10.100.1 255.255.255.0
ip helper-address 172.10.100.151
no ip redirects
no ip unreachables
no ip proxy-arp



4 REPLIES 4
Scott Fella
Hall of Fame Master

Since your AP is on a trunk port, you need to specify the native vlan for that port to vlan 101.  If the AP will tunnel back to the controller you don't need a trunk port just define an access vlan 101.

-Scott 

*** Please rate helpful posts *** 

-Scott
*** Please rate helpful posts ***

I've tried putting it with the native vlan to no avail. I statically assigned an IP and was able to connect to the controller so does that tell me that the DHCP server may be configured without option 43 or is that truly needed.

Leo Laohoo
VIP Community Legend

DHCP Option 43 is mandatory because this is where the AP is able to extract the information needed to know the exact IP address of the WLC.

Sandeep Choudhary
VIP Mentor

Hi,

paste the output of these commands:

sh sysinfo from wlc

sh version from AP

please also paste the boot-up process from AP console.

Info: If AP and WLC are not in same subnet then use option 43 method to discover WLC.

Regards

Dont forget to rate helpful posts

Content for Community-Ad