cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
744
Views
0
Helpful
11
Replies
Highlighted
Participant

Client not picking correct AP

Hello,

Just wondering if anyone has any ideas on why a client would not select the "better" AP?  This particular client see's 4 AP's and one of them is obviously the better one at -64.  Yet it inists that it wants to connect to one of the worst ones at -84.  There is no logic in it, and I don't see a way to force to to connect to the closer AP.

Thanks,
Dan.

11 REPLIES 11
Highlighted

It could have to do with the aggressive roaming setting on the client. It could also be that the client sees that AP as a 'known good' if its not been on the other AP before.

What rates do you have enabled? Disabling the lower rates can help with this.

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Highlighted

Rates:

802.11b/g

1 disabled

2 disabled

5.5 disabled

6 mandatory

9 supported

11 disabled

12 supported

18 supported

24 supported

36 supported

48 supported

54 supported

802.11a

6 disabled

9 disabled

12 disabled

18 supported

24 supported

36 mandatory

48 supported

54 supported

Highlighted

if you have to chnage PHY rates to make a client roam it means you have a crappy client or a client that is not config correctly

__________________________________________________________________________________________
"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
___________________________________________________________
Highlighted

I agree its most likely a crappy client.

HP 6735b

Broadcom 4322AG 802.11a/b/g/n

Driver 5.100.82.82

Highlighted

Dan,

Romaing is client specific. What is the client and driver ?

Some suuplicants like Intel ProSet have a roaming bar and even no roaming option if one wanted to stay sticky.

Supposing your APs are all config with the same SSID with no differences I might look into the client. Feel free to respond back wiith the NIC model and driver.

__________________________________________________________________________________________
"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
___________________________________________________________
Highlighted

Dan,

Another factor you should consider is power level of the AP. If the 2 APs are at the max power of 100mW, the client will still hear both and since the mandatory data rate is set at 6Mbps, the client can join any AP at that low rate. For a indoor office with cubicle walls the client can hear an AP set at 30mW with 2.2dBi antenna at approximately 310ft.

Remember that RSSI is relative and the figure you have might not paint a true picture. Hence -84dB doesn't mean that is exactly what it is.

I would suggest you reduce the power on the farthest away AP by 3-4 levels and the closest by 2 levels.

Highlighted

These AP's are located in a building with cinder block walls and concrete floors.  The location in question has the closest AP located behind a cinderblock wall, and the AP that the client wants to connect to through a concrete floor with steel plates and rebar.  The power is the same on both AP's.

I was thinking of adjusing the data rates, what rates would you recommend.  I would like to keep 802.11b disabled.

I have had bad luck with reducing power manually on the AP's, with odd things happening.  We have mass amounts of clients moving around the building and RRM needs to adjust them. 

Highlighted

Dan,

Most times the controller will instruct an AP to reduce power if it detects co-channel interference i.e another AP transmitting on the same channel. I am not really a great advocate of auto power settings because most times APs are at full blast until there is co-channel interference. Max power encourages hidden node problem.

Regarding what rates, it's hard to say because clients may support different data rates at the same RSSI level. For 802.11g, mandatory rates are 6,12, and 24. Hence you could disable 6 and 9 or change to supported and set your mandatory to 12 or disable 6,9, 12 and set mandatory to 24.

What is the distance of the problem client in relation to both APs? Have you taken the client closer to the AP behind the cinder wall and see if it still stays on the other AP.

Highlighted
Beginner

Nothing to do with the possibility that your APs with stronger signal are heavily loaded?

Sent from Cisco Technical Support iPad App

Highlighted

No that was one of the first things I checked.  The one that the client is supposed to connect to has one other client on it, and the others had more than a hand full.

Highlighted

I would check and verify that the drivers on the client are the most up to date. The client makes the decision on when to move not the wlc. You can do the following from the cli of the wlc the client is connecting to. Debug client (Mac address) in one cli and the other debug client (Mac address) Then have the client connect to the ap and have them start to move. The sho client detail will give you the information like SNR/RSSI ap connected to nearby neighbors. Then as they move away from the ap, you should start to see the rssi go more neg and the SNR to drop down from  for example 42 towards 20 and your rssi go from -50 up to -60 -65-70 and so on. You in most cases want your snr to be 22 or better.  disable the lower data rates may also help with client sticking