cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3699
Views
0
Helpful
5
Replies

Clients hung up on DHCP_REQD Policy state

hartsellda
Beginner
Beginner

I recently installed a new WLC 4402 after my old 4402 died after many years of use.  Upon installation, I am noticing that I am having all sorts of trouble getting clients to connect and get a valid DHCP number.  The clients are all Macintosh and are associated according to the controller but not authorized.  Upon checking a client, I find that they are hung up on DHCP_REQD policy manager state.  They have either a 0.0.0.0 address or a 192.168.2.x address.  This is happening to about 80% of the clients while the other 20% are connecting without any problems.  I'm serving DHCP from the controller itself.  Running 6.0.199.4 software version on the controller.  Any tips to troubleshoot would be appreciated.  Thank you for any help provided.

5 Replies 5

George Stefanick
VIP Alumni
VIP Alumni

There is a known bug on 6.x and 7.x with the controller DHCP. Cisco TAC released 7.0.98.4 is a fix. Also, its not a good idea to use the controller as a DHCP server. Ive had a lot of problems with it in the past.

Add a standalone DHCP server and see if this corrects your issue.

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
___________________________________________________________

Thanks for the replies.  I moved my DHCP to a standalone server and bumped my software version up to 7.0.98.0.  My DHCP issue seems to have been taken care of but now a new issue has popped up.  The connection to my management port keeps dropping at random times.  I've been monitoring it and it seems to happen when there are a large number of users connected but it has dropped a few times with very few.  I'm not able to connect to the controller at all when this happens and only a restart by powering down and back up fixes the problem until the next time.  I did notice before upgrading to 7.0.98.0 that port 1, which is my management port, had mirroring enabled.  I attempted to disable it but it constantly bounced back to enabled when I attempted to apply the change.  Once I upgraded to 7.0.98.0, I checked that port again and mirroring was no longer an option so I'm not sure if it is still enabled or not.  Could this be the problem with the loss of connection?  If so, where can I verify whether mirroring is enabled in version 7.0.98.0?  Any help would be appreciated.  Thank you!

Hi,

Mirror mode should be enabled only on an unused port as any connections to this port become unresponsive.

Hence i would suggest you to disable port mirror mode feature.

You can check this from the GUI by going to Controller -> Port -> Port no. -> Mirror Mode -> enable/disable.

Also, from the CLI you can enable it using the command "config mirror port " and disable it using the command "config mirror port none"

Please let me know if this helps

Regards,

Maithri

Thanks for the suggestion Maithri.  Unfortunately since I upgraded to software version 7.0.98.0, I am not able to use the GUI or CLI to configure the mirroring on any port.  Those commands just aren't available like they are in previous versions.  I am not sure if mirroring is not possible on the port with the newer software version or if there is just another way to configure it.  Thoughts?  Thanks again!

John Hudnall
Beginner
Beginner

I had the same issue last week. What I figured out was the controller (Software 6.0.196.0) can't handle more than about 489 dhcp addresses. Not sure if this is your issue, but I had to move my dhcp to our windows dhcp server to be able to handle the load.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: