cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
105
Views
0
Helpful
2
Replies

Configure Cisco ISR 1941W as Wireless Access point

viversector
Beginner
Beginner

Hi,

I am trying to configure a Cisco 1941W to act as a wireless access point for an existing wired network. Interface gi0/1 on the 1941 will connect to a switch that is using the 192.168.115.0/24 range. The 1941 will have the IP 192.168.115.239. 

Is anyone able to provide me basic steps that I need to configure the 1941 and the integrated wireless AP? I just need to get the basic config for the 1941 and the web interface running for the wireless AP so I can configure the wireless settings from there.  

Thanks!

2 Replies 2

Haydn Andrews
Engager
Engager

https://www.cisco.com/c/en/us/td/docs/routers/access/1900/software/configuration/guide/Software_Configuration/wlan.html

https://networklessons.com/uncategorized/cisco-1941w-wireless-configuration-example

these should help you

*****Help out other by using the rating system and marking answered questions as "Answered"*****
*** Please rate helpful posts ***

viversector
Beginner
Beginner

Thanks for those links, I must be doing something wrong, I don't seem to be able to ping 192.168.115.238 and 192.168.115.239 on the 1941 from a computer connected to the switch with an IP of 192.168.115.171.

My configs are below;

CR1941#sh run
Building configuration...

Current configuration : 1568 bytes
!
! Last configuration change at 11:56:44 UTC Wed Aug 17 2022
! NVRAM config last updated at 11:56:47 UTC Wed Aug 17 2022
!
version 15.7
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CR1941
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1941W-N/K9 sn FGL163325DQ
hw-module ism 0
!
!
redundancy
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface wlan-ap0
ip address 11.11.11.11 255.255.255.255
arp timeout 0
no mop enabled
no mop sysid
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Wlan-GigabitEthernet0/0
switchport mode access
no ip address
!
interface Vlan1
ip address 192.168.115.238 255.255.255.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
ntp server 34.202.215.187
!
end

 

The config for the embedded AP is below;

ap#sh run
Building configuration...

Current configuration : 2960 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ap
!
enable secret 5 $1$/Jnc$9gCAMcPRLdmY2b9cb.uTY1
!
no aaa new-model
!
!
dot11 syslog
!
!
username cisco privilege 15 secret 5 $1$7N8S$/O8Qu20ToS2LaTpsBZ/uZ1
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
shutdown
antenna gain 0
no dfs band block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0
description the embedded AP GigabitEthernet 0 is an internal interface connecting AP with the host router
no ip address
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 192.168.115.239 255.255.255.0
no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
privilege level 15
login local
no activation-character
line vty 0 4
login local
!
cns dhcp
end

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: