cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
676
Views
0
Helpful
7
Replies
pacsniffing
Beginner

DHCP not passing on one particular WLAN

  We currently have a cisco 4402 with firmware version 6.0.182.0 and 4 WLANs currently running on it, we found the need to add an additional WLAN and after the configuration was completed and I tried to connect to it I found that we are not getting an address.  If i connect a laptop to the VLAN I can get an IP and am able to browse.  If i hard code an IP into a device and connect to the wireless i am able to connect and browse.  Any Ideas would be appreciated, thanks.                

7 REPLIES 7
smayanja123
Beginner

You have to specify the DHCP server IP address on the interface you are using and on the WLAN -- Advanced, check the box DHCP Address Assignment Required. And another thing on the switch where you created the interface make sure you have Iphelper for the dhcp server. That should do it.

Sam

Sent from Cisco Technical Support iPad App

Arthur Burger
Beginner

Can you attach a screenshot of your interface and SSID configuration?

Alex Burger
CCNP|CCNP-Wireless|CCDA|MCITP
Cisco Borderless Networks Mobility/R&S Support Specialist

Alex

Sorry for not responding sooner guys, seems i have a much bigger problem on my hands.  The configuration on the Controller was correct, the device that was issuing DHCP addresses was a sonicwall.  I replaced it with a cisco 2600 router and the WLAN functioned as needed. My issue with that is why would one device work and not another?  I tend to worry about problems that seem to work themselves out because when it stops working again you're usually at a loss as to where to start looking.

WLC by default has dhcp proxy enabled, it is possible that sonicwall doesn't like unicast dhcp request from proxy Vs cisco 2600 router. Or with dhcp proxy disabled you didn't have ip helper on the L3 interface.

that is a very real possiblity, will have to try that on monday when i return to work.  that would help to put some closure before i can truly call this project complete.

I concur on the fw comment. I've hit that myself with the Asa. Then I forget the helper when I turn off proxy. Never fails, you can call me proxy spoiled I suppose !

Sent from Cisco Technical Support iPad App

"Satisfaction does not come from knowing the solution, it comes from knowing why." - Rosalind Franklin
___________________________________________________________

Well some FW's don't like when the WLC does proxy. Usually if you have trouble with the FW and dhcp, you need to disable Proxy. You do need proxy only if your using the WLC as a dhcp server.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
Content for Community-Ad