Showing results for 
Search instead for 
Did you mean: 

FTP/TFTP problem with transfer file on Wireless Controller 2504


Hi All

I would like to ask and post some question about FTP/TFTP problem when i associated wifi via controller 2504 version 7.6. I found that user cannot use FTP/TFTP protocol that user cannot transfer file at all. Anyway i tried to downgrade controller to be 7.4.110 version , user still got the same problem. At first i think it may have problem internal TFTP/FTP such as security or firewall but I tried FTP/TFTP via wired lan which can transfer file as well. User have not any problem or issue with FTP/TFTP. Right now, user and me think the problem may be on controller 2504, but i do not know the real issue or problem. Anyone or who found this problem or any comment, please help



14 Replies 14

No There can not be a problem with WLC. May be you are trying to reach to controller from wireless client.

Can you run this command and try again

WLC >network mgmt-via-wireless enable


Dont forget to rate helpful posts

Hi sandeepchoudhary21

I already done it before but client still cannot use ftp / tftp.



can you ping WLC to/from TFTP server(Vice versa) ??

Can you paste the error you are facing ?


Hi Sandeepchoudhary21

Yes our WLC and TFTP Server can ping together, I will found out the picture but let's me explain in detail

1. Client TFTP via wifi, it not response

2. Client tried to TFTP via wired line, it work and response as well.

3. Client tried to vpn to internal office and TFTP, it work and response as well.

So, i think that it have the problem when user tftp via wifi but i do not have any idea which part to mention.



means you can transfer file via wired or with VPN(internal office).

Only Problem is with Wireless TFTP client.

From Wireless tftp client, can you able to ping WLC ??

What error you are getting ?


Hi Sandeepchoudhary21

Yes, corrrect

Client can ping wlc,

I will try to copy picture to you



this wireless connection is just an internet connection ot its routed to internal network ??

Means you are getting IP on wireless client form your internal network ??


Hi Sandeepchoudhary21

I have check with client already, i may conclude the issue below;

1. our network only have 1 vlan, all server and client  are in the same vlan. ( WLC, PC and Server are ping together)

2. Client FTP to get file from FTP Server which very slow almost cannot get the file. If compare with normal getting for example ( Cmd > // > file ) this way can get the file and very fast also.

3. Client FTP via Wired or VPN from internal and external, it working and get the file very fast.

4. IP address from internal dhcp server.



Got Your Point.

Earlier I never used this with wireless client to transfer a file to WLC but right now I tried and its also not working for me.(Firewall and other things are ok for me )

So I think its not allowed or may be cisco will update these things in newer version of code.

Last you have to use wired connection to transfer the file to WLC.

Sorry My friend but this is the only way.

If you want to know more about this problem then you can raise a TAC case and ask the detail of this, surely they will guide you.


Dont forget to rate helpful posts

Hi sandeepchoudhary21

Thanks with your testing, I may raise a TAC case because i may difficult to customer because they are doing as mobile office.

Thank you so much


Yes TAC can provide you the all details about this and also let us know what TAC say about this.


Dont forget to rate helpful posts


kindly check the following link

and for CLI (document)


Using WCS to Upgrade the Wireless LAN Controller

Complete these steps in order to update controller (and access points) software using the Wireless Control System (WCS).

  1. Enter  ping ip address in the command prompt window in order to be sure that  the WCS server can reach the controller. If you use an external TFTP  server, enter ping ip address in order to be sure that the WCS server  can reach TFTP server.
  2. In the GUI interface, choose Configure > Controllers in order to navigate to the All Controllers page.
  3. Check  the check box of the desired controller, choose Download Software from  the Select a Command drop-down menu, and click Go. The WCS displays the  Download Software to Controller page.
  4. If you use the built-in  WCS TFTP server, check the TFTP Server on WCS System check box. If you  use an external TFTP server, uncheck this check box and add the external  TFTP server IP address.
  5. Click Browse and navigate to the  software update file (for example, AS_2000_release.aes for 2000 series  controllers).The files are uploaded to the root directory which was  configured for use by the TFTP server. You can change to a different  directory.
  6. Click Download.WCS downloads the software to the  controller, and the controller writes the code to Flash RAM. As WCS  performs this function, it displays its progress in the Status field.

Scott Fella
Hall of Fame Guru Hall of Fame Guru
Hall of Fame Guru

TFTP/FTP upload and download to a WLC is not allowed if your a wireless client associated to an access point to the WLC your trying to upload or download to. This has always been by design from v7.0x or earlier. You can TFTP or FTP from a wireless client to upload or download from the WLC if your associated to an access point that is joined to a different WLC.

Sent from Cisco Technical Support iPhone App

*** Please rate helpful posts ***

Not applicable

"Transfer in progress by another user"

ssue - "transfer in progress by another user"

Had this problem and file transfer was in progress for long hours with no options permitted.

"RESET SYSTEM FORCED" helped to reset and recovered from the tftp transfer that was for long hours.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers