Showing results for 
Search instead for 
Did you mean: 

"Update is Aborted" when trying to upgrade 1815i Mobility Express

Model: AIR-AP1815I-E-K9

Current software version:


So I'm trying to upgrade this AP's software (which is standalone and the only AP we have) to the latest version (although I have also tried older versions), but I'm getting "Update is Aborted" as a message at the top of the WUI and the 'State' says "Aborted" at the bottom under the 'Predownload Image Status' section, with the 'Download Percentage' saying 100% but with a red bar (unsure if the red bar actually even relates to the status though, but thought I'd mention it for extra detail).

I've tried uploading via HTTP and TFTP (exactly same procedure as shown here and get the same problem with both.

At this point I'm not even sure I've downloaded the right file, but I've been using the zip file (extracted) and pointing the file path to the extracted folder within the TFTP directory. But for my own sanity, I also put the TAR download in the same folder and it didn't make a difference.

Any clues?

This video is to demonstrate Software Update on Mobility Express from WebUI.This video relates to AireOS on Mobility Express.
VIP Advisor


 - Could you try the upgrade through the CLI ?



it could be there is not enogh space on the filesystem to download and extract the new image.

upgrade through CLI will give a more clear error is this occurs.


I managed to upgrade it in the end via the CLI, but I inadvertently went backwards before going forwards.
When I jumped on, I ran show boot and noticed that the 'backup boot image' was newer than the 'primary boot image', so I switched the boot mode to use the backup image and then rebooted because I was curious...

After rebooting, it seemed like I was no longer in Mobility Express (if that's the right thing to say) because my CLI was showing as APXXXX.XXXX.XXXX# instead of (Cisco Controller) >. I'm guessing Mobility Express wasn't installed on this image and I was at the OS level of the AP.

Anywho, I quickly found an article online about installing Mobility Express which simply said to run ap-type mobility-express tftp://, which I did and then rebooted. When it rebooted, it installed the Mobility Express image and then asked me to set up the AP, which was the only other annoyance I had because the upgrade basically reset the AP, but I didn't have a very complex configuration so it won't take too long to set it back up.

Once the AP was fully up again and I specified the admin username/password and management IP, I was able to log into the WUI and verify that the software was running the version I just installed (running show boot and show sysinfo via CLI also confirmed).

Content for Community-Ad