cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
985
Views
0
Helpful
8
Replies
Chieu Dinh
Beginner

Radio supported for 1200 series?

I am running the upgrade tool on Aironet AP1230B-A-K9. I can't join the controller by using the upgrade tool. the error is "AP does not have Supported Radio". What radio is the upgrade tool or controller look for on Aironet 1200 series? This AP is running 802.11b. However, I have several APs which the same model is running on the same one controller.  The controller is model 4402.

Any ideas?

8 REPLIES 8
blakekrone
Enthusiast

Only some versions can be upgraded:

For all IOS-based 1200  series modular access point (1200/1220 Cisco IOS Software Upgrade, 1210  and 1230 AP) platforms, it depends on the radio:

if 802.11G, MP21G and MP31G are supported

if 802.11A, RM21A and RM22A are supported

The 1200 series access points can be upgraded with any combination of supported radios: G only, A only, or both G and A.

http://www.cisco.com/en/US/docs/wireless/access_point/conversion/lwapp/upgrade/guide/lwapnote.html#wp157130

I can see my AP is had the supported radio. But the upgrade tool is complain this AP does not have supported radio.

I captured the detailed log in upgrade tool, it shows:

- user had Full privilege

- Getting AP name.

- AP has 12.3(7)JA image or greater.

- Term length configured

- Upgrade tool support AP.

- AP does not have Supported Radio.

It stopped here with error.

Do a "show controllers" from the CLI on the AP and post the output.

I found the information about this upgrade tool I want to share.

Before using this utility, consider the following important notes:

• Access points converted with this tool will not connect to 40xx, 41xx, or 3500 controllers.

• You cannot upgrade access points with 802.11b-only or first-generation 802.11a radios.

It means I can't use this tool to upgrade the AP with radio 802.11b only.

Thank you Blakekrone

No problem, please rate and mark answered so that others can find solutions in the future!

In this case, how do you convert autonomous AP to lightweight if you can't use upgrade tool? I manually archive download the lightweight image to the AP but it need the SSC so I can't join to the controller. Any ideas?

You would issue a debug pm pki on the WLC to retrieve the hash to add to the ap authorizations.

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_tech_note09186a008072d9a1.shtml

I dont know why but I am using this command many times but I did not receive any message or the hash key from this command.

debug mac addr < mac address of the AP>

debug capwap events enable

debug pm pki enable

These three commands does not give me anything. Any ideas?

Create
Recognize Your Peers
Content for Community-Ad