cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
301
Views
0
Helpful
1
Replies

Root bridge ..clients unable to get IP after association.

yprasannas
Level 1
Level 1

Root and non-root bridge connect fine. Here is the relevant config.....this does not work. However it works if I add WPA encryption with PSK in SSID and add encryption vlan 141 mode ciphers aes in the main interface dot11radio0 . Why is that?

dot11 ssid ridge-data

   vlan 141

   authentication open

   guest-mode

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

ssid ridge-data

!

ssid ridge-voip

!

antenna gain 0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.141

encapsulation dot1Q 141

no ip route-cache

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

bridge-group 2 spanning-disabled

interface Dot11Radio1

no ip address

no ip route-cache

!

encryption vlan 140 mode ciphers aes-ccm

!

ssid bridge1262

!

station-role root bridge

interface Dot11Radio1.140

encapsulation dot1Q 140 native

no ip route-cache

bridge-group 1

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

no keepalive

!

interface GigabitEthernet0.140

encapsulation dot1Q 140 native

no ip route-cache

bridge-group 1

interface GigabitEthernet0.141

encapsulation dot1Q 141

no ip route-cache

bridge-group 2

!

interface BVI1

ip address 192.13.114.194 255.255.255.0

no ip route-cache

!

ip default-gateway 192.13.114.1

1 Reply 1

yprasannas
Level 1
Level 1

Looks like STP issue between bridge and switch. After adding below config there is STP VLAN errors on the switch port. Had to enable BPDUFilter and clients get the IP. But they cannot reach GW. This works on a different switch so something related to IOS or platform.

bridge-group 3

bridge-group 3 subscriber-loop-control

bridge-group 3 block-unknown-source

no bridge-group 3 source-learning

no bridge-group 3 unicast-flooding

bridge-group 3 spanning-disabled

Review Cisco Networking for a $25 gift card