cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1045
Views
15
Helpful
4
Replies
fernando_garcia
Beginner

Preposition doesn't start

Hi, I'm trying to setup a preposition for a huge content (50 GB) but it doesn't work. CM says process is in progress, but nothing happens in the core WAE (not even in the Edge WAE).

Background:

CM version 4.3.1

Core WAE: 4.1.7, License Status: Enterprise, Video

In the CM I see the preposition status (after stoping and starting it):

esplpawae806 Mon Jan 17 16:21:21 CET 2011 31.319584 [min] 0.0 [bytes] In Progress

In the configuration I have:
CIFS Use legacy WAFS transport mode: disabled
Total Size as % of cache volume: 50   
No max file size
min file size 20 kB
No duration.
Type: all files
Location NNNN (where NNNN is a location with a single WAE that is placed near the file server).
We have configured the server, password, etc. correctly.
We have one edge device (esplpawae806)
In the core WAE (the one assigned to NNNN):
esplpawae801#sh statistics connection opt epm
Current Active Optimized Flows:                      39
   Current Active Optimized TCP Plus Flows:          39
   Current Active Optimized TCP Only Flows:          0
   Current Active Optimized TCP Preposition Flows:   0
Current Active Auto-Discovery Flows:                 8
Current Reserved Flows:                              10
Current Active Pass-Through Flows:                   0
Historical Flows:                                    542
esplpawae801#                    show accelerator cifs
Accelerator     Licensed        Config State    Operational State            
-----------     --------        ------------    -----------------            
cifs            Yes             Enabled         Running   
CIFS:
   Policy Engine Config Item            Value              
   -------------------------            -----              
   State                                Registered         
   Default Action                       Use Policy         
   Connection Limit                     1500               
   Effective Limit                      1490               
   Keepalive timeout                    5.0 seconds
If I made a "show run" in this WAE I don't see any preposition lines. From what I undestand it should have some lines configured from the CM.
What I'm making wrong?
Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
smnambia
Cisco Employee

Hi Fernando,

If you have preposition defined on the CM and have assigned the edge wae device and also scheduled the preposition,then on the edge wae device on which you plan to preposition the data when you run sh run,towards the end you should see something as similar to this

accelerator cifs preposition 5880
   name "test"
   server "2.8.3.1"
   root "test/"
   credentials username admin password 1 mencrypt{yB5ioOuZNyE=}
   max-cache 5
   min-file-size 20
   no ignore-hidden-dir
   recursive
   scan-type full
   schedule now
   enable
   modified 17:01:2011 08:54:55

If you are not seeing the above on your edge wae device,then please check the sh cms info output on the edge wae device and see when did it last sync with the CM.Also do a sh clock on the edge wae and verify if the last sync time is close to the sh clock output.

You can also sync the edge wae device with the CM using cms config-sync command.

The first step is to confirm that the preposition is being seen on the edge wae device when configured from the CM.I just tried it in my lab with 4.3.1 CM and wae device and it worked fine.

We have to both schedule the preposition and assign the edge wae device for the preposition to show up on the edge wae device.

So as per your config on wae (esplpawae806) that is your remote wae you should see the preposition config lines.You wont see it on the core wae device.

If the preposition is showing up on the edge wae device and still if you are seeing it constantly in progress state.Try first to create a preposition for a small file and verify if it works properly and then try the 50GB content again.

Regards

-Smita

View solution in original post

4 REPLIES 4
smnambia
Cisco Employee

Hi Fernando,

If you have preposition defined on the CM and have assigned the edge wae device and also scheduled the preposition,then on the edge wae device on which you plan to preposition the data when you run sh run,towards the end you should see something as similar to this

accelerator cifs preposition 5880
   name "test"
   server "2.8.3.1"
   root "test/"
   credentials username admin password 1 mencrypt{yB5ioOuZNyE=}
   max-cache 5
   min-file-size 20
   no ignore-hidden-dir
   recursive
   scan-type full
   schedule now
   enable
   modified 17:01:2011 08:54:55

If you are not seeing the above on your edge wae device,then please check the sh cms info output on the edge wae device and see when did it last sync with the CM.Also do a sh clock on the edge wae and verify if the last sync time is close to the sh clock output.

You can also sync the edge wae device with the CM using cms config-sync command.

The first step is to confirm that the preposition is being seen on the edge wae device when configured from the CM.I just tried it in my lab with 4.3.1 CM and wae device and it worked fine.

We have to both schedule the preposition and assign the edge wae device for the preposition to show up on the edge wae device.

So as per your config on wae (esplpawae806) that is your remote wae you should see the preposition config lines.You wont see it on the core wae device.

If the preposition is showing up on the edge wae device and still if you are seeing it constantly in progress state.Try first to create a preposition for a small file and verify if it works properly and then try the 50GB content again.

Regards

-Smita

View solution in original post

ktunugun
Cisco Employee

Hi Fernando,

When you start the preposition job or at the scheduled time when the job has to start, if you check the sh stat connection at the edge device do you see connections between the edge device and the file server? If yes what is the state of those connections whether they are shown as TDL ot Ss Sr?

Regards

Kiran.

Hi Kiran

Regarding your message and the one from Smita:

Yes, I see the preposition configurated in the edge device:

accelerator cifs preposition 18601797

   name "Preposition_Cartografia_Arucas"

   server "esplpa01fs02.esp.e-corpnet.org"

   root "distrdat/esquemas/"

   root "distrdat/GEST_EDI/"

   root "GIS/"

   credentials username ENDFSR-SRVC-SCHEDFSR domain esp password 1 xxxx

   max-cache 50

   min-file-size 20

   no ignore-hidden-dir

   recursive

   scan-type full

   schedule now

   enable

   modified 17:01:2011 16:55:31

exit

After three days  running the preposition is still in progress as seen by the CM:

esplpawae806 Mon Jan 17 16:21:21 CET 2011 2.7523232 [day] 0.0 [bytes] In Progress

The edge device can resolve the name of the server:

esplpawae806#ping        esplpa01fs02.esp.e-corpnet.org

PING esplpa01fs02.esp.e-corpnet.org (172.24.16.152) 56(84) bytes of data.

64 bytes from 172.24.16.152: icmp_seq=1 ttl=126 time=2.09 ms

64 bytes from 172.24.16.152: icmp_seq=2 ttl=126 time=2.08 ms

64 bytes from 172.24.16.152: icmp_seq=3 ttl=126 time=2.01 ms

64 bytes from 172.24.16.152: icmp_seq=4 ttl=126 time=2.03 ms

Now is office hour and in the edge device I see several connections to the server, all using port 445 and all are in TCDL state:

ConnID        Source IP:Port          Dest IP:Port            PeerID Accel RR  

508950     172.24.33.84:1107     172.24.16.152:445 00:1a:64:f2:2f:95 TCDL  98.9%

509105     172.24.33.81:1115     172.24.16.152:445 00:1a:64:f2:2f:95 TCDL  98.6%

509250     172.24.33.87:1143     172.24.16.152:445 00:1a:64:f2:2f:95 TCDL  98.4%

509804     172.24.33.80:1102     172.24.16.152:445 00:1a:64:f2:2f:95 TCDL  98.8%

510323     172.24.33.82:1103     172.24.16.152:445 00:1a:64:f2:2f:95 TCDL  98.7%

511245     172.24.33.85:1107     172.24.16.152:445 00:1a:64:f2:2f:95 TCDL  98.9%

The disk use don't show an increase of capacity used so I assume that no transfer is in place.

I still have no clue why it doesn't work. I'll try to schedule a smaller transfer.

Any ideas?

Hello all

Problem solved.

The fault was in the routers of the core. The ip wccp 61 and ip wccp 62 use a redirect-list that included the PCs used in the edge office but not the loopback IP of the WAE in the edge office so the preposition traffic didn't reach the core WAE.

We have added it's IP to the access list and now the preposition is working.

Thanks a lot for your help.