cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
971
Views
0
Helpful
5
Replies
oleg.syrbu1
Beginner

Loading tcl script

I use a tcl ivr application. Sometime when I reload script after some changings it hangs in loading process. 

Removing the application service and renaming it doesn't help. Only the router reboot helps. 

There isn't any hung session with this application. 

(ios ver c2800nm-advipservicesk9-mz.124-24.T8)

show call application voice

 nodes_ivr flash:nodes_ivr.tcl Loading...

//-1//SCRI:/ScriptList_ScriptLoad: Attempting to Load Script: nodes_ivr

 

My router is in work environment, and it's difficult to reload when it's needed.

I can't understand why it happens. Is there any way to reload buildin tcl module or somthing else what can help without the router reload?

5 REPLIES 5
Raghavendra G V
Cisco Employee

Hi,

There may be some errors in your script. Please share the logs with below debugs and if possible please share your script.

debug voip app.

Thanks,
Raghavendra

debug voip app writes only

//-1//SCRI:/ScriptList_ScriptLoad: Attempting to Load Script: nodes_ivr

The script is without any error, because I run it succsessfully on an other router. 

I tried to run this script from tftp but I cannot see any request from router on tftp server.  Somethig happened with call application loading process.

Besides I tried to reload all files linked with the script on the flash and noticed one of the files connot be deleted with error:

flash:/ivr/CDRs.txt (File in use in an incompatible mode)

And I can see active application, but I don't have this app servece I deleted it before. 

#show call application active app-level app-tag ivr
Application level active Info:

Application name: ivr
URL: flash:/ivr/ivr.tcl
Total sessions:

 

 

 

if there are no errors in script then this may be related to your file path issue.To reload the script in router you can use below command.
Router# call application voice load <ivr appliation name>

Thanks,
Ragahvendra

No, the file path is ok. 

The application can't be loaded no matter what I use a loading way( service or call application voice load).

Now I cannot load any my application service. I feel like  this issue is related to call application interface. Everything will work after  the router reboot but I'm interested in if there is any way to solve this issue without rebooting. 

Please share output of below commands
1)sh call application voice <app name>
2)sh call application sessions

You can try with different IOS version and see. to reload the script there is only one command "call application voice load <app name>"

Thanks,
Raghavendra
Content for Community-Ad

This widget could not be displayed.