cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1868
Views
15
Helpful
12
Replies
vivebatr
Cisco Employee

TCL script not able to play .wav file in ISR 4K

Hi all,

 

We have recently migrated few ISR G1s to ISR 4K and found that TCL script which was working previously with ISR G1 is now not working in ISR 4K. The script is being used for simple IVR (customized though). 

 

Issue description: When IP Phone user makes a call to H.323 VGW (thr' CUCM) and the script is being invoked through inbound dial-peer, the caller gets dead air or TCL is not able to play .wav file.

Any further help would be really appreciated.

Attaching TCL script and few logs.

-Vivek

 

12 REPLIES 12
Raghavendra G V
Cisco Employee

Hi Vivek,

 

which IOS version you are using ? can you share output of "show version" and logs with debug command.

"debug voip app"

 

Thanks,

Raghavendra

Thanks Raghavendra.

Please find attached 'debug voip app' logs.

IOS-XE: 3.16.6S

 

- Vivek

can you try with latest 16.x version. I think there is bug for ISR G3 with tcl script.

 

below media files are not playing is that correct ? are you able to collect digits ?

media play leg_incoming flash://01.au flash://01.au flash://01.au

 

Thanks,

Raghavendra

Hi Raghavendra,

Yes, that's the welcome prompt (01.au) and digit collection is working good.

Checked with 16.6.2 and same result. Any specific version you would suggest?

- Vivek

Have you tried other audio files ? To see if the different IOS changed the behavior of playing audio file?

Hi Vivek,

As yawming suggested try with different audio file and also add some silence between each file and try as below.

 

media play leg_incoming $source$header.au %s1 $source$header.au %s1 $source$header.au

 

Thanks,

Raghavendra

Checked with difference wav files from B-ACD (renamed it) and added silence as well, but same result. 

- Vivek

So I guess cannot play any audio file with any Tcl script in  ISR 4K ?

B-ACD (default TCL) is working fine on the same platform and IOS.

 

- Vivek

Do you have any simple script to play your not working audio file to see if it works with other script ?

 

001049: *Aug 7 13:13:48.676: //5//MSM :/ms_associateDone: First Buf Play at 00:02:59.155 of 01.au
001050: *Aug 7 13:13:48.676: //5//MSM :/ms_associateDone: 00:02:59.155, Tstart(ply: iSndDly 0)
001051: *Aug 7 13:13:48.679: //5//MSM :/ms_handle_stream_timer: >>ms_start_play()
001052: *Aug 7 13:13:48.679: //5//MSM :/ms_start_play: 00:02:59.158, Tstart(ply: i_dly 4)
001053: *Aug 7 13:13:48.723: //5//MSM :/ms_cbf: (p 00:02:59.202 z)
001054: *Aug 7 13:13:48.723: //5//MSM :/ms_stop_play: mgdTstop at 00:02:59.202 (cause MS_STOP_COMPLETE)
001055: *Aug 7 13:13:48.723: //5//MSM :/ms_stop_play: Play Stopped at 00:02:59.202

 

Looks like file was played but start and stop immediately

Can you please try 

media play 01.au 

 

directly without "flash://"

 

01.au is a long file why need to play 3 times ?

Hi,

 

Did find out whats happen ?

I'm with the same problem. The script work properly on 2900 router but when I try the same script on ISR 4000 I have a lot of problems.

Content for Community-Ad

This widget could not be displayed.