Showing results for 
Search instead for 
Did you mean: 

getting a blank screen after entering email address

I am on Windows 10 and I am getting just a blank screen after I enter my email address in Spark to log in. I am guessing it is trying to redirect to our ADFS server for login. the Web and Mobile seem to work fine but not the desktop app. See the image attached. spark.png

Cisco Employee

Brian - I believe I've seen this once personally on the Mac version - but it was matter of me having to update to the most recent build.  So that we can at least cross that off on the list of things to check, I assume you are on the most recent Windows version?  I don't see anything currently listed on the known Windows issues page but it may be worth a read in case anything jumps out at you:  Cisco Spark | Cisco Spark for Windows - Known Issues

So what was interesting is once I got home it brought up our companies ADFS login page and everything worked just fine. I wonder if something just wasn't getting routed correctly internally. I will check next time I get to the office if I restart and see if it works or not.

We are having the exact same issue. We went down the ADFS road but everything looks to be configured correctly.

It is just the desktop app internally. Did you find a solution?

Anyone resolve this yet? I am having the same issue. Thanks.

Webapp and ADFS/SSO work fine, just the Windows application that is getting the blank screen after the email is entered.


We are working with support now but it looks like the desktop application uses IE. If the security zone your internal domain falls into tries to pass SSO to the desktop app, it won't work because it is an external IE frame. That is why you get the blank page but it should fail back to prompting for credentials but never does.

It doesn't work with any non-domain computers but it still tries to pass the current users credentials to ADFS.

Thanks for the feedback. If support provides a fix, could you please post it here? Thanks.

Of course.

From my testing (I work with Skyler), we've found that for domain joined systems, adding our adfs server to the trusted or intranet zones in internet explorer allow for the spark desktop client to log in with SSO correctly.

For non-domain systems the desktop client will not do anything beyond showing a blank page regardless of the adfs server being set in intranet or trusted sites. Even changing those zones to prompt for username and password for the user authentication does not make any change. We also have set our intranet zone in ADFS to allow for forms authentication with no change.

All forms of the web client prompt for username and password in any of the browsers for both domain and non-domain systems, in any browser (Chrome, FF, IE).

My ticket with Spark support was escalated up to the developers and I have been testing with support for the last 2 weeks. I'll update this thread if we do find a solution.


We are having the same issue i just opened a ticket for this..


After doing some testing with custom client builds from spark support, we found a build that presented an ADFS login form correctly and allowed us to login with both non-domain joined computers and domain joined computers, irregardless of internet explorers trusted sites and intranet sites classification of our adfs server.

I am not sure of the exact fix much less why the blank page was appearing in the first place, but support said the patch was put into the pre-production environment and should be on the main client sometime soon but no ETA was given.


Have you tried changing the client machine DNS to We are able to resolve that on our clients with that fix for the initial authentication to SSO, then change it back.

This worked for Skype for Business on a Mac.

we were experiencing blank SSO screen. Changing the dns to worked.

Recognize Your Peers
Content for Community-Ad