cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
3646
Views
0
Helpful
13
Replies
Highlighted
Enthusiast

Jabber iOS Apple Push Notifications APN

13 REPLIES 13
Highlighted
Beginner

I'm having the same issue.  Followed the guide to the letter and still no dice. I have an open TAC case. They requested the following from me for troubleshooting:

Can you please send me the screenshot of the Cloud Onboarding page from the CUCM server?

 

Can you also try the below procedure, collect the logs and send it over:

 

  • Set the XCP Router and the XCP Config Manager logs to Debug level using the IMP Serviceability page
  • Reset Jabber client on the iOS device.
  • Log into Jabber
  • Place the Jabber application in the background, make a note of the time and send the user a Jabber IM/push notification (which shouldn’t pop up, in your case).
  • Place the Jabber application in the foreground, make a note of the time and send the user a Jabber IM/push notification (which should pop up, in your case).
  • Obtain a Jabber Problem Report
  • Collect the IMP XCP Router and the XCP Config Manager logs using the RTMT tool for the failure event

 

Set the logs levels back to Info on the IMP server.

 

Send me the logs and include the timestamp of the failed and working IM message.

I'll let you know what I hear back from them.

Ryan

Highlighted

I ended up doing the same thing. They asked me for the exact same procedure. I sent the logs over 24 hours ago. They're analyzing them right now.

Highlighted

After reviewing my logs, my TAC engineer has escalated to the BU

Highlighted

Have you checked your IM&P server DNS settings?  It appears mine (I only have 1 node) lost these during the upgrade somehow, as they were blank.  I will be fixing this and rebooting over the weekend and will post my results.  

Edit: This fixed my issue.  APNs are working as I expect.

Highlighted

My DNS settings are still good

Highlighted

Jakub, 

I went through the logs, looks like a cert issue. 

can you post the screenshot of the Cloud onboarding page from the CUCM?

Do you have the "I want Cisco to manage the Cisco Cloud Service CA certificates required for this trust" checked?

Thanks

Raj

Highlighted

I have the same problem. Jabber iPhone not getting Push notifications from IMP. Neither in local LAN nor through MRA! All configurations done according to Cisco Guide! In foreground app OK, in background no notifications! Cisco ASA shows that IM Presence sends packets to 443 WAN! 

Highlighted

I've been working on this with TAC for a while now. I have a session with another engineer on Tuesday. We'll see if we can get somewhere. If we do, I'll post back here

Highlighted

So in your case, still Push notifications do not work! OK, will be waiting for the info that you'll get from TAC! Thank you!!!

Highlighted

At last!!!! Cisco published on the 20th of May the solution. Patch for IM&P fix to support fetching of Access Token from Cisco Cloud, it fixes XCPConfigManager.

Download and install on IM&P Servers -> ciscocm.cup-xcp-configmgr-pns-11.5.1.SU2-v1.cop.sgn

Pay attention! Install ONLY with Push Notification already activated on CUCM! Otherwise it will NOT work!

Good luck!!!

Highlighted

I seriously just got an email two minutes ago with this same info from the TAC engineer. 

I'll give it a shot

Highlighted

:))

Just make sure to apply the patch, with Push Notification Enabled on CUCM!

Highlighted

Patch worked! Success :)