cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

961
Views
0
Helpful
5
Replies
Beginner

Jabber Login issue over MRA ( UDS Server Not Found)

Dear All,

we are having issue while login jabber through smartphones ( IOS /Android ) over MRA . CSF is working fine internally as well as externally . Internally cisco jabber is working fine for IOS and Android .

 

Expressway-c we are getting UDS Server failed logs kindly check the attached screenshot .

 

Troubleshooting done :

- Verified all the A and SRV records ( all the records properly resolving from expressway-c )

- Verified login in self care portal for all the cucm Servers

- reconfigured whole MRA setup in expressway-c and e

 

 

5 REPLIES 5
VIP Collaborator

Re: Jabber Login issue over MRA ( UDS Server Not Found)

If I understand, the devices that won't log in via MRA will log in when on-prem. Is that correct? Or are the working on-prem devices and the not working off-prem devices different devices?

 

Do you have a single cluster or multiple clusters? If multiple clusters, is ILS configured, and do the user accounts exist on all clusters?

 

Also, is this a single domain environment or multiple domains, and is the internal and external domain the same?

 

Also, for the Directory UC Service internally are you using UDS or LDAP as the resolver?

 

 

Beginner

Re: Jabber Login issue over MRA ( UDS Server Not Found)

Hi Maren,

yes all the devices is working in on-prem , we have only issue when devices is in Off-Prem. 

 

we have single cluster , I verified all the server is able to authenticate user via self care portal 

I checked user home cluster  for all the servers using this url https://X.X.X.X/cucm-uds/clusterUser?username=sushants and we got true result for this user in whole cluster .

 

We are having two domains

abc.com - internal

xyz.com - external

all the SRV records is properly advertised and we can see expressway-c is able to resolve all the A and SRV records . Kindly check below example of our SRV and A records 

_cisco-uds._tcp.xyz.com --- pointing to cucm.abc.com

_cuplogin._tcp.xyz.com--- pointing to IMP.abc.com

 

We are using directory UC Service is UDS .

VIP Collaborator

Re: Jabber Login issue over MRA ( UDS Server Not Found)

Ok. So first I would say that the _cuplogin SRV records are used if you are supporting a cluster that is version 8.6 or earlier. For v9 and later UC deployments, as long as the _cisco-uds records resolve correctly, the Jabber client won't request the _cuplogin record from DNS so it shouldn't hurt anything to have them. But you can also remove them.

Cisco Jabber 11.0 Planning Guide

 

_cuplogin

Provides the location of Cisco Unified Presence.

Sets Cisco Unified Presence as the authenticator.

  • Supports deployments with Cisco Unified Communications Manager and Cisco Unified Presence version 8.x.
  • Supports deployments where all clusters have not yet been upgraded to Cisco Unified Communications Manager 9.

 

 

As for external service discovery. Did you include a VoiceServiceDomain key in your jabber-config.xml file and the correct internal DNS components for the xyx.com domain? (Which allows the internal domain login to work when off-prem.) See this:

Collaboration Edge (MRA) with Split DNS Domains

Beginner

Re: Jabber Login issue over MRA ( UDS Server Not Found)

Yes I am agree with your points
How come windows clients working fine internally as well as externally.
Anyhow i open a case with Cisco let see what they are going to do
Highlighted
VIP Collaborator

Re: Jabber Login issue over MRA ( UDS Server Not Found)

Forgive me, I misunderstood. So the Windows clients are working internally and externally, but the IOS and Android are working internally but not externally. Please let us know what TAC says. Good luck!

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here