cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
8168
Views
0
Helpful
9
Replies
Highlighted
Enthusiast

Jabber UDS Service Discovery problem on CUCM 10.5(2)

Hi all,

I've a problem with Jabber about the service discovery. Jabber client resolve correctly the SRV query _cisco-uds._tcp.mydomain.it but it receive from the CUCM a wrong information within the file home-uds-info.xml  located in the folder:

%AppData%\Roaming\Cisco\Unified Communications\Jabber\CSF\Config

 

The file contain only 1 bad UDS url:


<?xml version="1.0" encoding="UTF-8"?><UcmConfigCache fileVersion="1.0"><homeUdsNodes><currentHomeUdsNode version="10.5.2"><![CDATA[https://cucmp:8443/cucm-uds/user/test1]................

 

CUCM Version is 10.5.2.10000-5 and IM&P is 10.5.2.10000-9, the systems are configured without DNS.

As you can see the url contains only the name of the node and so the client is not able to resolve it, furthermore the link contains only 1 server node while the CUCM cluster have 2 nodes. After adding a DNS server and a domain name on both CUCM and IM&P nodes, the same file contains multiple links with both IP Address and hostname for both the CUCM nodes and so the Jabber client is able to connect.

Is there a way to change the name to IP Address in the CUCM answer? I know that DNS is recommended but it does have not sense to use the hostname in the uds url if the DNS is not configured in the CUCM nodes, while if the DNS is configured the urls contain also the IP Address.

 

Thanks and Regards,

Christian

9 REPLIES 9
Highlighted
Hall of Fame Cisco Employee

Jabber clients rely very heavily on DNS and SRVs, not having either, will only cause you problems, and since SRVs are configured in the DNS server... why don't you use it??

Otherwise, configure all those servers in the hosts/lmhosts files of every single user who will use Jabber.

HTH

java

if this helps, please rate
Highlighted

Applications are installed in a lab where DNS isn't available and since that all servers are configured with the IP Address in the System->Server setting, i don't see the problem with not using the DNS for the application nodes.

In any case for my point of view the question is: why CUCM write within the file home-uds-info.xml the URL without IP Address if the DNS is disabled?. If the URL were provided with the IP, the DNS configuration on the nodes would not be mandatory.

 

Regards

Highlighted

I'm having this same issue however the UDS url is showing the wrong hostname (it is missing one of the characters)

It is not an issue with my DNS records they are correct:

SRV records ok

DNS A records ok

hostname set on CUCM (System>Servers) are correct

UC services are correct

Service profiles are correct

Does anyone know how the currentHomeUdsNode in home-uds-info.xml is populated? There has to be an incorrect hostname configured somewhere but I cannot find it anywhere.

As a result jabber does not login, it says cannot contact server. If I add a dns a record for the incorrect server name, then it works but this is bugging me.  

Highlighted

Could you recreate the issue and provide me a problem report? Also, did you try resetting the cache?

The Home UDS Node info is provided by the CUCM which is contacted by Jabber client. Either the same CUCM would be the Home Node, or the other CUCM clusters would be connected using ILS (Intercluster Lookup Service)

Highlighted
Beginner

hello,

CUCM : 10.5.2.10000-5 CUP 10.5.2.20000-1 the systems are configured without DNS too.

I have same problem  in next enviroment - windows pc(not in domain) have workgroup not same as domain and connect over openvpn(dns and dns suffix from lan ) , but if you change workgroup to you domain -  jabber work.

If you cant change workgroup - change hosts file -  jabber work.

i think this small bug.

WBR, Dmitry.

Highlighted
Hall of Fame Cisco Employee

I suggest you review the directory integration chapter from the jabber documentation to understand why your scenario does not work

HTH

java

if this helps, please rate
Highlighted
Beginner

Hi Christian,

I've the same problem with you. Can you solve it yet? Please share if you can solve it already.

All CUCM and IMP servers in the System > Server are configured with IP Address too, but it always return the wrong URL in home-uds-info.xml. That is why I cannot login to Jabber client with "Cannot communicate with server" message.

But after I tried to manually change the URL in home-uds-info.xml from hostname to IP Address, the Jabber client can login and working fine.

Thanks

 

Highlighted

Hi benyathip,

 i had to instal a linux virtual machine with a DNS service for resolve the Cisco VM hostname and set the DNS on the CUCM and IM&P.

All the configuration in the CUCM servers has been unchanged and has remained with the IP address, i have only set the DNS and the domain.

By doing that, the file home-uds-info.xml is populated correctly with the IP address in the url...

 

Btw it is a nonsense, if you configure your system without the DNS the file home-uds-info.xml doesn't contains the IP address, if you use the DNS the file home-uds-info.xml contains the IP address... oh well.

 

Regards,

Christian

Highlighted

Hi Christian,

Many thanks for sharing your solution. I'm just thinking that is maybe a small bug as Dmitry said.

Content for Community-Ad